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Notice
While reasonable efforts have been made to ensure that the 
information in this document is complete and accurate at the time 
of printing, Avaya assumes no liability for any errors. Avaya reserves 
the right to make changes and corrections to the information in this 
document without the obligation to notify any person or organization 
of such changes.
Documentation disclaimer
“Documentation” means information published in varying mediums 
which may include product information, operating instructions and 
performance specifications that are generally made available to users 
of products. Documentation does not include marketing materials. 
Avaya shall not be responsible for any modifications, additions, or 
deletions to the original published version of Documentation unless 
such modifications, additions, or deletions were performed by or on 
the express behalf of Avaya. End User agrees to indemnify and hold 
harmless Avaya, Avaya's agents, servants and employees against 
all claims, lawsuits, demands and judgments arising out of, or in 
connection with, subsequent modifications, additions or deletions to 
this documentation, to the extent made by End User.
Link disclaimer
Avaya is not responsible for the contents or reliability of any linked 
websites referenced within this site or Documentation provided by 
Avaya. Avaya is not responsible for the accuracy of any information, 
statement or content provided on these sites and does not 
necessarily endorse the products, services, or information described 
or offered within them. Avaya does not guarantee that these links will 
work all the time and has no control over the availability of the linked 
pages.
Warranty
Avaya provides a limited warranty on Avaya hardware and software. 
Refer to your sales agreement to establish the terms of the 
limited warranty. In addition, Avaya’s standard warranty language, 
as well as information regarding support for this product while under 
warranty is available to Avaya customers and other parties through 
the Avaya Support website: https://support.avaya.com/helpcenter/
getGenericDetails?detailId=C20091120112456651010 under the link 
“Warranty & Product Lifecycle” or such successor site as designated 
by Avaya. Please note that if You acquired the product(s) from an 
authorized Avaya Channel Partner outside of the United States and 
Canada, the warranty is provided to You by said Avaya Channel 
Partner and not by Avaya.
“Hosted Service” means an Avaya hosted service subscription that 
You acquire from either Avaya or an authorized Avaya Channel 
Partner (as applicable) and which is described further in Hosted SAS 
or other service description documentation regarding the applicable 
hosted service. If You purchase a Hosted Service subscription, 
the foregoing limited warranty may not apply but You may be 
entitled to support services in connection with the Hosted Service 
as described further in your service description documents for the 
applicable Hosted Service. Contact Avaya or Avaya Channel Partner 
(as applicable) for more information.
Hosted Service
THE FOLLOWING APPLIES ONLY IF YOU PURCHASE AN 
AVAYA HOSTED SERVICE SUBSCRIPTION FROM AVAYA OR 
AN AVAYA CHANNEL PARTNER (AS APPLICABLE), THE TERMS 
OF USE FOR HOSTED SERVICES ARE AVAILABLE ON THE 
AVAYA WEBSITE, HTTPS://SUPPORT.AVAYA.COM/LICENSEINFO 
UNDER THE LINK “Avaya Terms of Use for Hosted Services” 
OR SUCH SUCCESSOR SITE AS DESIGNATED BY AVAYA, AND 
ARE APPLICABLE TO ANYONE WHO ACCESSES OR USES THE 
HOSTED SERVICE. BY ACCESSING OR USING THE HOSTED 
SERVICE, OR AUTHORIZING OTHERS TO DO SO, YOU, ON 
BEHALF OF YOURSELF AND THE ENTITY FOR WHOM YOU ARE 
DOING SO (HEREINAFTER REFERRED TO INTERCHANGEABLY 
AS “YOU” AND “END USER”), AGREE TO THE TERMS OF USE. 
IF YOU ARE ACCEPTING THE TERMS OF USE ON BEHALF A 
COMPANY OR OTHER LEGAL ENTITY, YOU REPRESENT THAT 
YOU HAVE THE AUTHORITY TO BIND SUCH ENTITY TO THESE 
TERMS OF USE. IF YOU DO NOT HAVE SUCH AUTHORITY, 

OR IF YOU DO NOT WISH TO ACCEPT THESE TERMS OF 
USE, YOU MUST NOT ACCESS OR USE THE HOSTED SERVICE 
OR AUTHORIZE ANYONE TO ACCESS OR USE THE HOSTED 
SERVICE.
Licenses
THE SOFTWARE LICENSE TERMS AVAILABLE ON THE 
AVAYA WEBSITE, HTTPS://SUPPORT.AVAYA.COM/LICENSEINFO, 
UNDER THE LINK “AVAYA SOFTWARE LICENSE TERMS (Avaya 
Products)” OR SUCH SUCCESSOR SITE AS DESIGNATED BY 
AVAYA, ARE APPLICABLE TO ANYONE WHO DOWNLOADS, 
USES AND/OR INSTALLS AVAYA SOFTWARE, PURCHASED 
FROM AVAYA INC., ANY AVAYA AFFILIATE, OR AN AVAYA 
CHANNEL PARTNER (AS APPLICABLE) UNDER A COMMERCIAL 
AGREEMENT WITH AVAYA OR AN AVAYA CHANNEL PARTNER. 
UNLESS OTHERWISE AGREED TO BY AVAYA IN WRITING, 
AVAYA DOES NOT EXTEND THIS LICENSE IF THE SOFTWARE 
WAS OBTAINED FROM ANYONE OTHER THAN AVAYA, AN 
AVAYA AFFILIATE OR AN AVAYA CHANNEL PARTNER; AVAYA 
RESERVES THE RIGHT TO TAKE LEGAL ACTION AGAINST 
YOU AND ANYONE ELSE USING OR SELLING THE SOFTWARE 
WITHOUT A LICENSE. BY INSTALLING, DOWNLOADING OR 
USING THE SOFTWARE, OR AUTHORIZING OTHERS TO 
DO SO, YOU, ON BEHALF OF YOURSELF AND THE 
ENTITY FOR WHOM YOU ARE INSTALLING, DOWNLOADING 
OR USING THE SOFTWARE (HEREINAFTER REFERRED TO 
INTERCHANGEABLY AS “YOU” AND “END USER”), AGREE TO 
THESE TERMS AND CONDITIONS AND CREATE A BINDING 
CONTRACT BETWEEN YOU AND AVAYA INC. OR THE 
APPLICABLE AVAYA AFFILIATE (“AVAYA”).
Avaya grants You a license within the scope of the license types 
described below, with the exception of Heritage Nortel Software, 
for which the scope of the license is detailed below. Where the 
order documentation does not expressly identify a license type, 
the applicable license will be a Designated System License as 
set forth below in the Designated System(s) License (DS) section 
as applicable. The applicable number of licenses and units of 
capacity for which the license is granted will be one (1), unless a 
different number of licenses or units of capacity is specified in the 
documentation or other materials available to You. “Software” means 
computer programs in object code, provided by Avaya or an Avaya 
Channel Partner, whether as stand-alone products, pre-installed on 
hardware products, and any upgrades, updates, patches, bug fixes, 
or modified versions thereto. “Designated Processor” means a single 
stand-alone computing device. “Server” means a set of Designated 
Processors that hosts (physically or virtually) a software application 
to be accessed by multiple users. “Instance” means a single copy 
of the Software executing at a particular time: (i) on one physical 
machine; or (ii) on one deployed software virtual machine (“VM”) or 
similar deployment.
License type(s)
Designated System(s) License (DS). End User may install and use 
each copy or an Instance of the Software only: 1) on a number 
of Designated Processors up to the number indicated in the order; 
or 2) up to the number of Instances of the Software as indicated 
in the order, Documentation, or as authorized by Avaya in writing. 
Avaya may require the Designated Processor(s) to be identified in 
the order by type, serial number, feature key, Instance, location or 
other specific designation, or to be provided by End User to Avaya 
through electronic means established by Avaya specifically for this 
purpose.
Concurrent User License (CU). End User may install and use the 
Software on multiple Designated Processors or one or more Servers, 
so long as only the licensed number of Units are accessing and 
using the Software at any given time as indicated in the order, 
Documentation, or as authorized by Avaya in writing. A “Unit” means 
the unit on which Avaya, at its sole discretion, bases the pricing of 
its licenses and can be, without limitation, an agent, port or user, an 
e-mail or voice mail account in the name of a person or corporate 
function (e.g., webmaster or helpdesk), or a directory entry in the 
administrative database utilized by the Software that permits one 
user to interface with the Software. Units may be linked to a specific, 
identified Server or an Instance of the Software.
Cluster License (CL). End User may install and use each copy or 
an Instance of the Software only up to the number of Clusters as 
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indicated on the order, Documentation, or as authorized by Avaya in 
writing with a default of one (1) Cluster if not stated.
Enterprise License (EN). End User may install and use each copy 
or an Instance of the Software only for enterprise-wide use of an 
unlimited number of Instances of the Software as indicated on the 
order, Documentation, or as authorized by Avaya in writing.
Named User License (NU). End User may: (i) install and use 
each copy or Instance of the Software on a single Designated 
Processor or Server per authorized Named User (defined below); 
or (ii) install and use each copy or Instance of the Software on 
a Server so long as only authorized Named Users access and 
use the Software as indicated in the order, Documentation, or as 
authorized by Avaya in writing. “Named User”, means a user or 
device that has been expressly authorized by Avaya to access and 
use the Software. At Avaya’s sole discretion, a “Named User” may 
be, without limitation, designated by name, corporate function (e.g., 
webmaster or helpdesk), an e-mail or voice mail account in the 
name of a person or corporate function, or a directory entry in the 
administrative database utilized by the Software that permits one 
user to interface with the Software.
Shrinkwrap License (SR). End User may install and use the Software 
in accordance with the terms and conditions of the applicable 
license agreements, such as “shrinkwrap” or “clickthrough” license 
accompanying or applicable to the Software (“Shrinkwrap License”) 
as indicated in the order, Documentation, or as authorized by Avaya 
in writing.
Transaction License (TR). End User may use the Software up to the 
number of Transactions as specified during a specified time period 
and as indicated in the order, Documentation, or as authorized by 
Avaya in writing. A “Transaction” means the unit by which Avaya, 
at its sole discretion, bases the pricing of its licensing and can 
be, without limitation, measured by the usage, access, interaction 
(between client/server or customer/organization), or operation of the 
Software within a specified time period (e.g. per hour, per day, per 
month). Some examples of Transactions include but are not limited 
to each greeting played/message waiting enabled, each personalized 
promotion (in any channel), each callback operation, each live agent 
or web chat session, each call routed or redirected (in any channel). 
End User may not exceed the number of Transactions without 
Avaya’s prior consent and payment of an additional fee.
Heritage Nortel Software
“Heritage Nortel Software” means the software that was acquired 
by Avaya as part of its purchase of the Nortel Enterprise Solutions 
Business in December 2009. The Heritage Nortel Software is the 
software contained within the list of Heritage Nortel Products located 
at https://support.avaya.com/LicenseInfo under the link “Heritage 
Nortel Products” or such successor site as designated by Avaya. 
For Heritage Nortel Software, Avaya grants Customer a license to 
use Heritage Nortel Software provided hereunder solely to the extent 
of the authorized activation or authorized usage level, solely for the 
purpose specified in the Documentation, and solely as embedded 
in, for execution on, or for communication with Avaya equipment. 
Charges for Heritage Nortel Software may be based on extent of 
activation or use authorized as specified in an order or invoice.
Copyright
Except where expressly stated otherwise, no use should be made 
of materials on this site, the Documentation, Software, Hosted 
Service, or hardware provided by Avaya. All content on this site, the 
documentation, Hosted Service, and the product provided by Avaya 
including the selection, arrangement and design of the content is 
owned either by Avaya or its licensors and is protected by copyright 
and other intellectual property laws including the sui generis rights 
relating to the protection of databases. You may not modify, copy, 
reproduce, republish, upload, post, transmit or distribute in any way 
any content, in whole or in part, including any code and software 
unless expressly authorized by Avaya. Unauthorized reproduction, 
transmission, dissemination, storage, and or use without the express 
written consent of Avaya can be a criminal, as well as a civil offense 
under the applicable law.
Virtualization
The following applies if the product is deployed on a virtual machine. 
Each product has its own ordering code and license types. Unless 
otherwise stated, each Instance of a product must be separately 

licensed and ordered. For example, if the end user customer or 
Avaya Channel Partner would like to install two Instances of the 
same type of products, then two products of that type must be 
ordered.
Third Party Components
“Third Party Components” mean certain software programs or 
portions thereof included in the Software or Hosted Service may 
contain software (including open source software) distributed under 
third party agreements (“Third Party Components”), which contain 
terms regarding the rights to use certain portions of the Software 
(“Third Party Terms”). As required, information regarding distributed 
Linux OS source code (for those products that have distributed Linux 
OS source code) and identifying the copyright holders of the Third 
Party Components and the Third Party Terms that apply is available 
in the products, Documentation or on Avaya’s website at: https://
support.avaya.com/Copyright or such successor site as designated 
by Avaya. The open source software license terms provided as 
Third Party Terms are consistent with the license rights granted in 
these Software License Terms, and may contain additional rights 
benefiting You, such as modification and distribution of the open 
source software. The Third Party Terms shall take precedence over 
these Software License Terms, solely with respect to the applicable 
Third Party Components to the extent that these Software License 
Terms impose greater restrictions on You than the applicable Third 
Party Terms.
The following applies only if the H.264 (AVC) codec is distributed 
with the product. THIS PRODUCT IS LICENSED UNDER THE AVC 
PATENT PORTFOLIO LICENSE FOR THE PERSONAL USE OF A 
CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE 
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH 
THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC 
VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A 
PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO 
PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE 
IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. 
ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, 
L.L.C. SEE HTTP://WWW.MPEGLA.COM.
Service Provider
THE FOLLOWING APPLIES TO AVAYA CHANNEL PARTNER’S 
HOSTING OF AVAYA PRODUCTS OR SERVICES. THE PRODUCT 
OR HOSTED SERVICE MAY USE THIRD PARTY COMPONENTS 
SUBJECT TO THIRD PARTY TERMS AND REQUIRE A 
SERVICE PROVIDER TO BE INDEPENDENTLY LICENSED 
DIRECTLY FROM THE THIRD PARTY SUPPLIER. AN AVAYA 
CHANNEL PARTNER’S HOSTING OF AVAYA PRODUCTS MUST 
BE AUTHORIZED IN WRITING BY AVAYA AND IF THOSE 
HOSTED PRODUCTS USE OR EMBED CERTAIN THIRD PARTY 
SOFTWARE, INCLUDING BUT NOT LIMITED TO MICROSOFT 
SOFTWARE OR CODECS, THE AVAYA CHANNEL PARTNER 
IS REQUIRED TO INDEPENDENTLY OBTAIN ANY APPLICABLE 
LICENSE AGREEMENTS, AT THE AVAYA CHANNEL PARTNER’S 
EXPENSE, DIRECTLY FROM THE APPLICABLE THIRD PARTY 
SUPPLIER.
WITH RESPECT TO CODECS, IF THE AVAYA CHANNEL 
PARTNER IS HOSTING ANY PRODUCTS THAT USE OR 
EMBED THE H.264 CODEC OR H.265 CODEC, THE AVAYA 
CHANNEL PARTNER ACKNOWLEDGES AND AGREES THE 
AVAYA CHANNEL PARTNER IS RESPONSIBLE FOR ANY AND 
ALL RELATED FEES AND/OR ROYALTIES. THE H.264 (AVC) 
CODEC IS LICENSED UNDER THE AVC PATENT PORTFOLIO 
LICENSE FOR THE PERSONAL USE OF A CONSUMER 
OR OTHER USES IN WHICH IT DOES NOT RECEIVE 
REMUNERATION TO: (I) ENCODE VIDEO IN COMPLIANCE WITH 
THE AVC STANDARD (“AVC VIDEO”) AND/OR (II) DECODE AVC 
VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A 
PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO 
PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE 
IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. 
ADDITIONAL INFORMATION FOR H.264 (AVC) AND H.265 (HEVC) 
CODECS MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://
WWW.MPEGLA.COM.
Compliance with Laws
You acknowledge and agree that it is Your responsibility for 
complying with any applicable laws and regulations, including, but not 
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limited to laws and regulations related to call recording, data privacy, 
intellectual property, trade secret, fraud, and music performance 
rights, in the country or territory where the Avaya product is used.
Preventing Toll Fraud
“Toll Fraud” is the unauthorized use of your telecommunications 
system by an unauthorized party (for example, a person who is not a 
corporate employee, agent, subcontractor, or is not working on your 
company's behalf). Be aware that there can be a risk of Toll Fraud 
associated with your system and that, if Toll Fraud occurs, it can 
result in substantial additional charges for your telecommunications 
services.
Avaya Toll Fraud intervention
If You suspect that You are being victimized by Toll Fraud and You 
need technical assistance or support, call Technical Service Center 
Toll Fraud Intervention Hotline at +1-800-643-2353 for the United 
States and Canada. For additional support telephone numbers, 
see the Avaya Support website: https://support.avaya.com or such 
successor site as designated by Avaya.
Security Vulnerabilities
Information about Avaya’s security support policies can be 
found in the Security Policies and Support section of https://
support.avaya.com/security.
Suspected Avaya product security vulnerabilities are handled 
per the Avaya Product Security Support Flow (https://
support.avaya.com/css/P8/documents/100161515).
Downloading Documentation
For the most current versions of Documentation, see the Avaya 
Support website: https://support.avaya.com, or such successor site 
as designated by Avaya.
Contact Avaya Support
See the Avaya Support website: https://support.avaya.com for 
product or Hosted Service notices and articles, or to report a 
problem with your Avaya product or Hosted Service. For a list of 
support telephone numbers and contact addresses, go to the Avaya 
Support website: https://support.avaya.com (or such successor site 
as designated by Avaya), scroll to the bottom of the page, and select 
Contact Avaya Support.
Trademarks
The trademarks, logos and service marks (“Marks”) displayed in this 
site, the Documentation, Hosted Service(s), and product(s) provided 
by Avaya are the registered or unregistered Marks of Avaya, its 
affiliates, its licensors, its suppliers, or other third parties. Users 
are not permitted to use such Marks without prior written consent 
from Avaya or such third party which may own the Mark. Nothing 
contained in this site, the Documentation, Hosted Service(s) and 
product(s) should be construed as granting, by implication, estoppel, 
or otherwise, any license or right in and to the Marks without the 
express written permission of Avaya or the applicable third party.
Avaya is a registered trademark of Avaya Inc.
All non-Avaya trademarks are the property of their respective owners. 
Linux® is the registered trademark of Linus Torvalds in the U.S. and 
other countries.
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Chapter 1: IP Office Embedded Voicemail

The IP Office IP500 V2 and IP500 V2A control units support Embedded Voicemail by default. 
Embedded Voicemail provides basic voicemail and automated attendant operation without requiring 
a separate voicemail server.

Embedded Voicemail uses the following components:

• IP500 V2/V2A Control Unit – The control unit uses the system's mandatory System SD card 
for storage of the Embedded Voicemail prompts and messages.

• Licenses(Optional) – For non-subscription systems, by default the system provides 15 hours 
of storage and 2 simultaneous connections without requiring any licenses. Using licenses, that 
can be increased up to 25 hours of storage and 6 simultaneous connections.

Embedded Voicemail cannot be used in conjunction with another voice mail server. For example, IP 
Office Embedded Voicemail cannot be used with Voicemail Pro server. Similarly, it cannot be used 
by a network of servers, The presence of another voice mail server on the same network might 
cause Embedded Voicemail to fail to operate correctly and vice versa.

Related links
What's New on page 8
Mailbox features on page 9
Embedded Voicemail Summary on page 9
Languages supported on page 10
Default/Fallback Language Operation on page 11
What's New on page 8
Mailbox features on page 9
Embedded Voicemail Summary on page 9
Languages supported on page 10
Default/Fallback Language Operation on page 11

What's New
The following new features apply to IP Office R11.1 FP1.

• Hunt Group Voicemail Operation - Previously unanswered calls to a hunt group went 
to voicemail when they reached the group's no answer time. They now go to the group's 
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fallback destination, which can be configured to an extension number, system short code or 
voicemail. This operation is configured through the Group > Fallback tab.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Mailbox features
The system automatically creates a mailbox for every user and hunt group in the system’s 
configuration.

• For users, the mailbox is automatically used to answer calls direct to the user that ring 
unanswered for the user's configured No Answer Time. The mailbox is also used in other 
situations where the system would have otherwise returned a busy tone, for example when 
the user is set to Do Not Disturb.

• For hunt groups, the mailbox is used when a call has rung for the group's Group No Answer 
Time and the Group No Answer Destination is set to Voicemail.

• For security, a voicemail access code can be assigned to any mailbox. This can be changed 
by the mailbox user or the system administrator.

• For user mailboxes, message waiting indication is provided to the user's phone extension 
and to their user application.

• For hunt group mailboxes, message waiting indication can be assigned to specified users.

• Various dialing short codes can be used to control voicemail features and for actions such as 
collecting messages, leaving messages, and turning voicemail on and off. See Default short 
codes on page 69 for more information.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Embedded Voicemail Summary
Feature Details
Control Unit IP500 V2 and IP500 V2A
Memory type Uses the System SD Card
Compression method Uses G711. No VCM channels required.

Table continues…

Mailbox features
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Feature Details
Storage 25 hours maximum

For systems not running in subscription mode, 15 hours by default. 
An additional 5 hours is added for each 2 additional channels licensed 
(see below).

Maximum simultaneous 
connections

6 channels maximum

For systems not running in subscription mode, 2 channels by default. 
Additional channels require licenses.

Maximum individual message 
length

Default 120 seconds.

Adjustable between 3 and 180 seconds
Auto attendants Yes. Up to 40.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Languages supported
Embedded Voicemail supports the following language prompt sets:

Locale WAV folder
Arabic[1] ara
Chinese – Cantonese zhh
Chinese – Mandarin chs
Danish dan
Dutch nld
English UK eng
English US enu
Finnish fin
French fra
French–Canadian frc
German deu
Italian ita
Japan jpn
Korean kor
Mediterranean heb
Norwegian nor

Table continues…
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Locale WAV folder
Polish plk
Portuguese ptg
Portuguese-Brazil ptb
Russian rus
Spanish esp
Spanish-Argentina ess
Spanish-Mexico esm
Swedish sve
Turkish trk

Note:
• The Arabic prompt set is only supported on systems running in Basic Edition modes.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Default/Fallback Language Operation
The system Locale setting sets the default language used for voicemail prompts. However, this 
can be overridden as follows:

• The user locale, if set, is used if the caller is internal.
• The incoming call route locale, if set, is used if the caller is external.
• If no user or incoming call route locale is set, the system locale is used.
• A short code locale, if set, is used and overrides the options above if the call is routed to 

voicemail using the short code.
• For all the above, if the particular prompt set is not available, the fallback language is used if 

available.

Locale Default Language Fallback Languages
Argentina Latin Spanish Spanish > UK English > US English
Australia UK English US English
Bahrain Arabic[1] UK English > US English

Belgium (Dutch) Dutch Dutch > UK English > US English
Belgium (French) French French > Canadian French> UK English

Brazil Brazilian Portuguese Portuguese > UK English > US English

Table continues…

Default/Fallback Language Operation
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Locale Default Language Fallback Languages
Canadian Canadian French French > US English > UK English

Chile Latin Spanish Spanish > US English
China Mandarin UK English > US English

Colombia Latin Spanish Spanish > US English
Czech Republic UK English US English

Denmark Danish UK English > US English
Egypt Arabic[1] UK English > US English

Finland Finnish UK English > US English
France French Canadian French > UK English > US English

France 2 French Canadian French > UK English > US English
Germany German UK English > US English
Greece UK English US English

Hong Kong Cantonese UK English > US English
Hungary UK English US English
Iceland UK English US English
India UK English US English
Italy Italian UK English > US English

Japan (Japanese) Japanese US English > UK English
Japan US English UK English > US English
Korea UK English UK English > US English
Kuwait Arabic[1] UK English > US English

Malaysia UK English US English
Mediterranean Hebrew UK English > US English

Mexico Latin Spanish Spanish > UK English > US English
Morocco French French > UK English > US English

Netherlands Dutch UK English > US English
New Zealand (UK 

English)
UK English UK English > US English

Norway Norwegian UK English > US English
Oman Arabic[1] UK English > US English

Pakistan UK English UK English > US English
Peru Latin Spanish Spanish > UK English

Philippines US English UK English
Poland Polish UK English > US English

Portugal Portuguese UK English > US English

Table continues…
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Locale Default Language Fallback Languages
Qatar Arabic[1] UK English > US English
Russia Russian UK English > US English

Saudi Arabia UK English US English
Singapore UK English US English

South Africa UK English US English
Spain Spanish Latin Spanish > UK English > US English

Sweden Swedish UK English > US English
Switzerland French UK English
Switzerland German UK English > US English
Switzerland Italian UK English > US English

Taiwan Mandarin UK English > US English
Turkey Turkish UK English > US English

United Arab Emirates UK English US English
United Kingdom UK English US English
United States US English UK English

Venezuela Latin Spanish Spanish > US English

Note:
• The Arabic prompt set is only supported on systems running in Basic Edition modes.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Default/Fallback Language Operation
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Chapter 1: IP Office Embedded Voicemail

The IP Office IP500 V2 and IP500 V2A control units support Embedded Voicemail by default. 
Embedded Voicemail provides basic voicemail and automated attendant operation without requiring 
a separate voicemail server.

Embedded Voicemail uses the following components:

• IP500 V2/V2A Control Unit – The control unit uses the system's mandatory System SD card 
for storage of the Embedded Voicemail prompts and messages.

• Licenses(Optional) – For non-subscription systems, by default the system provides 15 hours 
of storage and 2 simultaneous connections without requiring any licenses. Using licenses, that 
can be increased up to 25 hours of storage and 6 simultaneous connections.

Embedded Voicemail cannot be used in conjunction with another voice mail server. For example, IP 
Office Embedded Voicemail cannot be used with Voicemail Pro server. Similarly, it cannot be used 
by a network of servers, The presence of another voice mail server on the same network might 
cause Embedded Voicemail to fail to operate correctly and vice versa.

Related links
What's New on page 8
Mailbox features on page 9
Embedded Voicemail Summary on page 9
Languages supported on page 10
Default/Fallback Language Operation on page 11
What's New on page 8
Mailbox features on page 9
Embedded Voicemail Summary on page 9
Languages supported on page 10
Default/Fallback Language Operation on page 11

What's New
The following new features apply to IP Office R11.1 FP1.

• Hunt Group Voicemail Operation - Previously unanswered calls to a hunt group went 
to voicemail when they reached the group's no answer time. They now go to the group's 
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fallback destination, which can be configured to an extension number, system short code or 
voicemail. This operation is configured through the Group > Fallback tab.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Mailbox features
The system automatically creates a mailbox for every user and hunt group in the system’s 
configuration.

• For users, the mailbox is automatically used to answer calls direct to the user that ring 
unanswered for the user's configured No Answer Time. The mailbox is also used in other 
situations where the system would have otherwise returned a busy tone, for example when 
the user is set to Do Not Disturb.

• For hunt groups, the mailbox is used when a call has rung for the group's Group No Answer 
Time and the Group No Answer Destination is set to Voicemail.

• For security, a voicemail access code can be assigned to any mailbox. This can be changed 
by the mailbox user or the system administrator.

• For user mailboxes, message waiting indication is provided to the user's phone extension 
and to their user application.

• For hunt group mailboxes, message waiting indication can be assigned to specified users.

• Various dialing short codes can be used to control voicemail features and for actions such as 
collecting messages, leaving messages, and turning voicemail on and off. See Default short 
codes on page 69 for more information.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Embedded Voicemail Summary
Feature Details
Control Unit IP500 V2 and IP500 V2A
Memory type Uses the System SD Card
Compression method Uses G711. No VCM channels required.

Table continues…

Mailbox features
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Feature Details
Storage 25 hours maximum

For systems not running in subscription mode, 15 hours by default. 
An additional 5 hours is added for each 2 additional channels licensed 
(see below).

Maximum simultaneous 
connections

6 channels maximum

For systems not running in subscription mode, 2 channels by default. 
Additional channels require licenses.

Maximum individual message 
length

Default 120 seconds.

Adjustable between 3 and 180 seconds
Auto attendants Yes. Up to 40.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Languages supported
Embedded Voicemail supports the following language prompt sets:

Locale WAV folder
Arabic[1] ara
Chinese – Cantonese zhh
Chinese – Mandarin chs
Danish dan
Dutch nld
English UK eng
English US enu
Finnish fin
French fra
French–Canadian frc
German deu
Italian ita
Japan jpn
Korean kor
Mediterranean heb
Norwegian nor

Table continues…

IP Office Embedded Voicemail
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Locale WAV folder
Polish plk
Portuguese ptg
Portuguese-Brazil ptb
Russian rus
Spanish esp
Spanish-Argentina ess
Spanish-Mexico esm
Swedish sve
Turkish trk

Note:
• The Arabic prompt set is only supported on systems running in Basic Edition modes.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Default/Fallback Language Operation
The system Locale setting sets the default language used for voicemail prompts. However, this 
can be overridden as follows:

• The user locale, if set, is used if the caller is internal.
• The incoming call route locale, if set, is used if the caller is external.
• If no user or incoming call route locale is set, the system locale is used.
• A short code locale, if set, is used and overrides the options above if the call is routed to 

voicemail using the short code.
• For all the above, if the particular prompt set is not available, the fallback language is used if 

available.

Locale Default Language Fallback Languages
Argentina Latin Spanish Spanish > UK English > US English
Australia UK English US English
Bahrain Arabic[1] UK English > US English

Belgium (Dutch) Dutch Dutch > UK English > US English
Belgium (French) French French > Canadian French> UK English

Brazil Brazilian Portuguese Portuguese > UK English > US English

Table continues…

Default/Fallback Language Operation
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Locale Default Language Fallback Languages
Canadian Canadian French French > US English > UK English

Chile Latin Spanish Spanish > US English
China Mandarin UK English > US English

Colombia Latin Spanish Spanish > US English
Czech Republic UK English US English

Denmark Danish UK English > US English
Egypt Arabic[1] UK English > US English

Finland Finnish UK English > US English
France French Canadian French > UK English > US English

France 2 French Canadian French > UK English > US English
Germany German UK English > US English
Greece UK English US English

Hong Kong Cantonese UK English > US English
Hungary UK English US English
Iceland UK English US English
India UK English US English
Italy Italian UK English > US English

Japan (Japanese) Japanese US English > UK English
Japan US English UK English > US English
Korea UK English UK English > US English
Kuwait Arabic[1] UK English > US English

Malaysia UK English US English
Mediterranean Hebrew UK English > US English

Mexico Latin Spanish Spanish > UK English > US English
Morocco French French > UK English > US English

Netherlands Dutch UK English > US English
New Zealand (UK 

English)
UK English UK English > US English

Norway Norwegian UK English > US English
Oman Arabic[1] UK English > US English

Pakistan UK English UK English > US English
Peru Latin Spanish Spanish > UK English

Philippines US English UK English
Poland Polish UK English > US English

Portugal Portuguese UK English > US English

Table continues…

IP Office Embedded Voicemail
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Locale Default Language Fallback Languages
Qatar Arabic[1] UK English > US English
Russia Russian UK English > US English

Saudi Arabia UK English US English
Singapore UK English US English

South Africa UK English US English
Spain Spanish Latin Spanish > UK English > US English

Sweden Swedish UK English > US English
Switzerland French UK English
Switzerland German UK English > US English
Switzerland Italian UK English > US English

Taiwan Mandarin UK English > US English
Turkey Turkish UK English > US English

United Arab Emirates UK English US English
United Kingdom UK English US English
United States US English UK English

Venezuela Latin Spanish Spanish > US English

Note:
• The Arabic prompt set is only supported on systems running in Basic Edition modes.

Related links
IP Office Embedded Voicemail on page 8
IP Office Embedded Voicemail on page 8

Default/Fallback Language Operation
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Chapter 2: Installing Embedded Voicemail

Embedded voicemail is the default voicemail used by new or defaulted IP500 V2 and IP500 V2A 
systems. It uses the System SD card installed in the control unit for prompts and for voicemail 
storage. However, additional configuration may be required for specific features and for systems that 
are upgraded to a new release of IP Office software.

Related links
Embedded Voicemail task worksheet on page 20
Checking and Uploading Prompts on page 21
Configuring Embedded Voicemail on page 23
Memory card removal on page 24
Memory card startup on page 25

Embedded Voicemail task worksheet
# Section Description
1. Upgrade prompts on 

page 21
A set of prompts are provided on Embedded Voicemail 
memory cards supplied by Avaya. However these may not 
match the full set of prompts required for new features in your 
systems installed version of IP Office.

2. Configuring Embedded 
Voicemail on page 23

Set the IP Office to use Embedded Voicemail and set the 
maximum record time for messages, greetings and prompts.

3. User mailbox configuration on 
page 27

Configure the personal settings for individual users.

4. Hunt group mailbox 
configuration on page 41

Configure the settings for any hunt groups where voicemail is 
required. This includes configuring message waiting indication 
and mailbox access which are not enabled by default.

5. Auto attendant 
configuration on page 50

Setup any required auto attendant services and associate 
them with incoming call routes.

Related links
Installing Embedded Voicemail on page 20
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Checking and Uploading Prompts
When you install a new System SD card in an IP500 V2 or IP500 V2A system, a default set of 
languages is loaded on the card. You can upload additional language prompt sets if required. For 
example, when you upgrade to a new release of software, it is possible that new features require 
additional prompts. See Uploading additional language prompts on page 22 for more information.

You can also reload languages that are already installed on the System SD card. For example, 
you can reload languages if new prompts have been added in a maintenance release. See 
Reloading language prompts on page 22 for more information.

All the prompts for Embedded Voicemail are found in the C:\Program Files 
(x86)\Avaya\IP Office\Manager\MemoryCards\Common\system\lvmail folder after 
the IP Office Administrator Applications are installed.

Related links
Installing Embedded Voicemail on page 20
Checking the prompt sets on page 21
Uploading additional language prompts on page 22
Reloading language prompts on page 22
Transferring the prompt files using IP Office Manager on page 22

Checking the prompt sets
About this task
Additional Embedded Voicemail features added in new IP Office releases may require new 
prompts. The system can be checked to see if it is reporting that any expected prompts are 
missing.

Procedure
1. From the Start menu, select IP Office > Monitor.
2. Select File > Select Unit.
3. Enter details for connection to the system.

4. Select Filters > Trace Options > System > Error.
5. Click OK.

Error messages like the following example are output at regular intervals:
158267586mS ERR: EVM 7p0 upgrade file clips missing
158267587mS ERR: EVM 7p2 upgrade file clips missing

Related links
Checking and Uploading Prompts on page 21

Checking and Uploading Prompts
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Uploading additional language prompts
About this task
You can perform this task on active systems only. The Add/Display VM Locales button is not 
available for offline configurations.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click System.

3. Select Voicemail.
4. Click the Add/Display VM Locales button.

5. Select the prompt set you want to upload.

6. Click OK.

7. Save the configuration back to the system (File > Save Configuration).

Related links
Checking and Uploading Prompts on page 21

Reloading language prompts
About this task
Use this task to reload language prompts that are already installed on the System SD card.

Procedure
1. Open IP Office Manager.

2. Select File > Advanced > Upgrade.

3. Click the check box for the appropriate system.

4. Click Upgrade.

5. Click the Upload System Files check box to select this option.

6. Click OK.

7. Save the configuration back to the system (File > Save Configuration).

Related links
Checking and Uploading Prompts on page 21

Transferring the prompt files using IP Office Manager
About this task
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Installing Embedded Voicemail
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Caution:
• Do not transfer prompt files if the level of IP Office Manager software is not appropriate 

for the IP Office system.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. Select File > Advanced > Embedded File Management.
3. Click the check box for the appropriate system.

4. Click OK.

5. Enter the same user name and password as used for normal system configuration..

6. Click OK.

7. Select File > Upload System Files. The prompt files installed with IP Office Manager and 
the IP Office firmware files are transferred.

Related links
Checking and Uploading Prompts on page 21

Configuring Embedded Voicemail
About this task
This task requires a system reboot. A system reboot ends all current calls and operation for a 
period of up to 5 minutes.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the left navigation pane, select System.

3. Click the Voicemail tab.

4. In the Voicemail Type drop-down box, select Embedded Voicemail.
5. The system’s mailboxes can operate in one of two modes, In the Voicemail Mode drop-

down box, select either:

• IP Office – This is the default for new and defaulted A-law systems.

• Intuity – This is the default for new and defaulted U-law systems.

6. If Enforcement is enabled, you can select various password enforcement options:

• Minimum length – Sets the minimum mailbox password length allowed. The default is 6 
digits.

Configuring Embedded Voicemail
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• Complexity – When enabled, the following complexity rules are enforced for new 
mailbox passwords:

- No forward or reverse sequence of numbers. For example, 1234 or 4321.
- No repeated digits. For example, 1111 or 2222.
- No match to the extension number.

7. In the Maximum Record Time field, set the value required by the customer. The allowable 
range is 30 to 180 seconds. The default setting is 110 seconds.

8. If Enable Outcalling is selected, users are able to use and configure mailbox outcalling 
options.

9. Click the System tab.

10. Make sure the Locale setting matches the language for spoken prompts required from the 
Embedded Voicemail. If it is not correct, consult with the customer first. This Locale setting 
controls many default aspects of IP Office operation and is normally already set to match 
the customer's locale.

If the configuration a set of locale language prompts that is not present on the System SD 
card, IP Office Manager displays a warning message. Click the warning to open a window 
and follow the prompts to add the locales. Alternatively, click Add/Display VM Locales 
and select the language to upload.

11. Click OK.

12. Select File > Save Configuration to send the changes back to the system and restart it. 
Embedded voicemail is not started immediately after the system restarts. There is a delay 
while the system performs housekeeping operations on the existing set of messages and 
prompts. On a new system the delay is less than a minute. However, as the number of 
messages increases the delay increases

13. Once the IP Office system has restarted, from an extension on the system, dial *17. The 
Embedded Voicemail answers and starts to give you prompts.

Related links
Installing Embedded Voicemail on page 20

Memory card removal
The memory card should never be simply removed from a system during normal operation. Doing 
so can cause the corruption of files in use. Either the memory card or the whole system must be 
shutdown before removing a memory card.

While the card is shutdown, voicemail is not available to the system. Any other services that use 
the memory card are also disabled. Features licensed by the System SD card continue for up to 2 
hours while the card is not present.

Once a memory card has been removed, reinserting the memory card automatically restarts it.

Installing Embedded Voicemail
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Related links
Installing Embedded Voicemail on page 20
Shutting down a memory card using Manager on page 25
Shutting down a memory card using System Status on page 25

Shutting down a memory card using Manager
Procedure

1. In IP Office Manager, select File > Advanced > Memory Card Command > Shutdown.

2. When prompted to continue, click Yes.

3. Select the system and enter an administrator name and password.

4. Select System.

5. At the back of the control unit, confirm that the appropriate memory card LED is off.

6. Remove the card.

Related links
Memory card removal on page 24

Shutting down a memory card using System Status
Procedure

1. Open System Status and access the status output.

2. In the navigation pane, select System > Memory cards.

3. If prompted, select System SD.

4. At the bottom of the window, click Shutdown.

5. At the back of the control unit, confirm that the appropriate memory card LED is off.

6. Remove the card.

Related links
Memory card removal on page 24

Memory card startup
Reinserting a memory card into a system that is already switched on will automatically restart card 
operation. However, if the card has been shutdown but not removed, it can be restarted without 
requiring a reboot.

Related links
Installing Embedded Voicemail on page 20
Starting up a memory card using Manager on page 26

Memory card startup
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Starting up a memory card using System Status on page 26

Starting up a memory card using Manager
About this task
Use this task to restart a memory card without removing and reinserting it.

Procedure
1. In IP Office Manager, select File > Advanced > Memory Card Command > Startup.

2. Select the system and enter an administrator name and password.

3. Select System.

4. Click OK.

Related links
Memory card startup on page 25

Starting up a memory card using System Status
About this task
Use this task to restart a memory card without removing and reinserting it.

Procedure
1. Open System Status and access the status output.

2. In the navigation pane, select System > Memory cards.

3. Click System SD or Optional SD.

4. At the bottom of the window, click Startup.

Related links
Memory card startup on page 25

Installing Embedded Voicemail
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Chapter 3: User mailbox configuration

Embedded voicemail creates a mailbox for each user on the system. Direct calls to a user are 
routed to their mailbox whenever the user's extension is busy or does not answer within the 
user's No Answer Time. This includes calls that are forwarded to another internal destination. 
This chapter describes how to configure an individual user's mailbox by configuring the user settings 
in IP Office Manager. An individual user's mailbox can also be configured through the mailbox and 
system short codes (see the IP Office Embedded Voicemail User Guide for more information).

User mailbox features include:

• Message Waiting Indication – If supported by the user's current telephone, the user will 
receive message waiting indication whenever their mailbox contains new messages. The type 
of message waiting indication will depend on the telephone.

• Mailbox access – The standard default short code (*17) can be used to access an extension's 
associated user mailbox. Other methods of mailbox access can be configured.

• Visual Voicemail — The MESSAGES button on phones is configured by default to access 
visual voicemail.

• Ringback – Embedded voicemail can be set to ring the user whenever they have new 
messages in their mailbox. This ringback is triggered after the completion of a call at the user's 
extension. Ringback from a hunt group mailbox containing new messages may also occur if the 
user is configured to receive hunt group message waiting indication.

• Voicemail on or off – Sending calls to the user's mailbox can be switched off. Note however 
that this does not stop other methods of leaving messages directly in the user's mailbox.

• Access code – An access code can be assigned to the mailbox. Anyone accessing the 
mailbox must first enter this code before they can collect messages. The access code can be 
reset by the user once they are in their mailbox.

• Reception/DTMF breakout numbers – Options can be configured that allows callers to dial 
0, 2 or 3 when they hear the mailbox greeting to be transferred to another number rather than 
leave a message. For example, dial 0 to be transferred to the receptionist. When used, these 
features should be announced in the mailbox greeting. The breakout numbers can be defined 
at the system level for application to all mailboxes or separately at the individual user level.

• Announcements – Embedded voicemail allows announcements to calls waiting to be 
answered by users. This is similar to the announcements provided for hunt groups, with 
announcements being played to callers waiting to be answered. Due to the overlap of various 
timeouts, the use of user announcements is not recommended in conjunction with forwarding 
and voicemail.
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• Voicemail Email – A user can have notification of new messages sent to their email address. 
The notification can be a simple alert to tell them they have a new message or the voicemail 
message can be sent if required. See Configuring voicemail email integration on page 31 for 
more information.

Related links
Changing a user's voicemail configuration on page 28
User Voicemail Settings on page 29
Configuring voicemail email integration on page 31
Announcements on page 33
Using pre-recorded names, greetings and announcements on page 35
Other Mailbox Message Waiting Indication on page 37
Editing a User's Trusted Locations on page 38

Changing a user's voicemail configuration
About this task
Mailboxes are created based on each user's unique user name within the IP Office configuration. 
Changing a user name associates that user with a new mailbox. If it is necessary to change a 
user name, ensure that they have played and deleted all their messages first. If a user name is 
changed without clearing the original mailbox, you must create a short code based on the old user 
name in order to access the old mailbox.
Use this task to change the voicemail configuration for an individual. A lock symbol indicates that 
the setting can also be set and locked through user rights. See the IP Office Manager on-line help 
or user documentation for more information.
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click User and select the required user.

3. Select Voicemail.
4. Change the fields as appropriate. See User Voicemail Settings on page 29 for more 

information.

5. Click OK.

6. Repeat steps 3 through 6 for each user as appropriate.

7. Save the configuration back to the system (File > Save Configuration).

Related links
User mailbox configuration on page 27

User mailbox configuration
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User Voicemail Settings
Name Description
Voicemail Code Default = Blank, Range = 0 (no code) to 15 digits.

This field sets the mailbox access code. This code is required for access to the 
mailbox from any source that is not a trusted location.

If remote access is attempted to a mailbox that has no voicemail code set, the 
prompt, “Remote access is not configured on this mailbox” is played.

If password enforcement has been enabled for the system, the voicemail code 
cannot:

• be the same as the extension number

• be the same as the previous code

• contain any consecutive digits

• contain repeated digits

• be shorter than the system’s minimum password length setting
Voicemail On Default = On.

When on, calls to the user's number go to voicemail if all not answered within 
their No Answer Time or if they have selected Do Not Disturb. Note that 
unselecting this option does not disable use of the user's mailbox. Messages 
can still be forward to their mailbox and the mailbox can still be accessed to 
collect messages.

Voicemail Help Default = Off.

Help can also be accessed by dialing *4 after accessing the mailbox.
Voicemail Ringback Default = Off.

When enabled, and a new message has been received, the voicemail server 
calls the user's extension to attempt to deliver the message each time the 
telephone is put down. Voicemail will not ring the extension more than once 
every 30 seconds. Supported in Intuity emulation mode only.

Voicemail Email 
Reading

This setting is not used for embedded voicemail.

UMS Web Services This setting is not used for embedded voicemail.
Voicemail Email Default = Blank (No voicemail email features).

This field is used to set the user or group email address used for voicemail 
email operation. When an address is entered, additional Voicemail Email 
controls described below are selectable.

Table continues…
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Name Description
Voicemail Email Default = Off.

If an email address is entered for the user or group, the following options 
become selectable. These options control the mode of automatic voicemail 
email operation provided by the voicemail server whenever the voicemail 
mailbox receives a new voicemail message.

• Off — If select, voicemail email is not used. Users can select this mode by 
dialing *03 from their extension.

• Copy — If selected, each time a new voicemail message is received in 
the voicemail mailbox, a copy of the message is attached to an email and 
sent to the email address. There is no mailbox synchronization between 
the email and voicemail mailboxes. For example, reading and deleting the 
email message does not affect the message in the voicemail mailbox or the 
message waiting indication provided for that new message.

• Forward — If selected, each time a new voicemail message is received 
in the voicemail mailbox, that message is attached to an email and sent 
to the email address. No copy of the voicemail message is retained in the 
voicemail mailbox and their is no message waiting indication. Like the Copy 
option, there is no mailbox synchronization between the email and voicemail 
mailboxes. Users can select this mode by dialing *01 from their extension.

• Alert — If selected, each time a new voicemail message is received in the 
voicemail mailbox, a simple email message is sent to the email address. This 
is an email message announcing details of the voicemail message but with 
no copy of the voicemail message attached. Users can select this mode by 
dialing *02 from their extension.

DTMF Breakout When a caller is directed to voicemail to leave a message, they can be given 
the option to be transferred to a different extension. The mailbox greeting 
message needs to be recorded telling the caller the options available. The 
extension numbers that they can be transferred to are entered in the DTMF 
breakout fields described below.

System default values can be set for these numbers and are used unless a 
different number is set within these user settings.

• Reception/Breakout (DTMF 0) — The number to which a caller is 
transferred if they press 0 while listening to the mailbox greeting or leaving a 
message.

• Breakout (DTMF 2) — The number to which a caller is transferred if they 
press 2 while listening to the mailbox greeting or leaving a message.

• Breakout (DTMF 3) — The number to which a caller is transferred if they 
press 3 while listening to the mailbox greeting or leaving a message.

Related links
User mailbox configuration on page 27
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Configuring voicemail email integration
About this task
Voicemail email integration uses the system's SMTP settings to send messages to the customer's 
email server. That server then forwards those messages into the user email mailboxes.
Once enabled, users can select to have an email alert about each new voicemail message or 
to have the voicemail message forwarded to their email mailbox. In addition, when listening to a 
message in their voicemail mailbox, they can forward it to their email mailbox.

Caution:
Any .wav files sent across a network creates a high loading on the network and network 
servers. A one-minute message requires a 1MB .wav file.

Related links
User mailbox configuration on page 27
Configuring System SMTP Support on page 31
SMTP tab field descriptions on page 31
Configuring User Voicemail Email on page 32

Configuring System SMTP Support
Before you begin
Obtain details of the customer's SMTP email server. It may be necessary to configure a user 
account on that server in order for it to accept and relay emails from the IP Office.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click System.

3. Click the SMTP tab.

4. Complete the following fields to match the customer SMTP server. See SMTP tab field 
descriptions on page 31 for more information.

5. Save the configuration back to the system (File > Save Configuration).

6. If the SMTP configuration was changed, restart the system.

Related links
Configuring voicemail email integration on page 31

SMTP tab field descriptions
Path: System > SMTP

Configuring voicemail email integration

October 2022 Embedded Voicemail Installation 31
Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Embedded Voicemail Installation


Name Description
Server Address The IP address of the customer's SMTP server. If not on the same subnet as 

the IP Office LAN, an IP route must also be added.
Port The SMTP listening port of the server. The default is 25.
Email From 
AddressEmail From 
Address

This is the address used by the system. Some servers only relay messages 
from recognized full addresses or addresses in the same domain.

Use STARTTLS Select this field to enable TLS/SSL encryption. Encryption allows voicemail-to-
email integration with hosted email providers that only permit SMTP over a 
secure transport.

Server Requires 
Authentication

If the server requires a user account to receive and send emails, enter the 
details of an account configured on that server for use by the system.

Use Challenge 
Response 
Authentication (CRAM-
MD5)

If SMTP uses CRAM-MD5, this option should be selected.

Related links
Configuring voicemail email integration on page 31

Configuring User Voicemail Email
Procedure

1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click User and select the required user.

3. Select Voicemail.
4. In the Voicemail Email field, enter the user's email address.

5. In the Voicemail Email section, click one of the following radio buttons:

• Off — If select, voicemail email is not used. Users can select this mode by dialing *03 
from their extension.

• Copy — If selected, each time a new voicemail message is received in the voicemail 
mailbox, a copy of the message is attached to an email and sent to the email address. 
There is no mailbox synchronization between the email and voicemail mailboxes. For 
example, reading and deleting the email message does not affect the message in the 
voicemail mailbox or the message waiting indication provided for that new message.

• Forward — If selected, each time a new voicemail message is received in the voicemail 
mailbox, that message is attached to an email and sent to the email address. No copy 
of the voicemail message is retained in the voicemail mailbox and their is no message 
waiting indication. Like the Copy option, there is no mailbox synchronization between 
the email and voicemail mailboxes. Users can select this mode by dialing *01 from their 
extension.

• Alert — If selected, each time a new voicemail message is received in the voicemail 
mailbox, a simple email message is sent to the email address. This is an email message 
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announcing details of the voicemail message but with no copy of the voicemail message 
attached. Users can select this mode by dialing *02 from their extension.

6. Click OK.

7. Save the configuration back to the system (File > Save Configuration).

Related links
Configuring voicemail email integration on page 31

Announcements
Announcements are played to callers waiting to be answered. For a hunt group, this includes both 
callers ringing at an agent and still queued.  

• If no voicemail channel is available for an announcement, the announcement is not played.
• Calls can be answered during the announcement.
• If a call is rerouted to a hunt group's Night Service Destination or Out of Service 

Destination, the announcements settings of the new destination are applied.  
• If a call overflows, the announcements of the original group are still applied, not those of the 

overflow group.
• For announcements configured for hunt groups to be used effectively, the hunt group's 

Group No Answer Time must be extended.
• For announcements configured for users to be used effectively, the user's No Answer Time 

must be extended or Voicemail On must be unselected.

Related links
User mailbox configuration on page 27
Configuring announcements on page 33
User Announcement settings on page 34
Recording announcements using short codes on page 34

Configuring announcements
Procedure

1. Using IP Office Manager, receive the configuration from the system.

2. In the left navigation pane, do one of the following:

• To configure an announcement for a user, click User.
• To configure an announcement for a hunt group, click Group.

3. Click the Announcements tab.

4. Set the fields to the appropriate values. See Group Announcement settings on page 48
for more information.
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5. Click OK.

6. Save the configuration back to the system (File > Save Configuration).

Related links
Announcements on page 33

User Announcement settings
Path: User > Announcements

Name Description
Announcements On Default = Off.

This setting enables or disables announcements.
Wait before 1st 
announcement

Default = 10 seconds. Range = 0 to 9999 seconds.

This setting sets the time delay from the calls presentation, after which the first 
announcement should be played to the caller.

Flag call as answered Default = Off.

This setting is not currently used.
Post announcement 
tone

Default = Music on hold.

Following the first announcement, you can select whether the caller should 
hear music on hold, ringing, silence until answered, or hear another 
announcement.

2nd Announcement Default = On.

If selected, a second announcement can be played to the caller if they have 
still not been answered.

Wait before 2nd 
announcement

Default = 20 seconds. Range = 0 to 9999 seconds.

This setting sets the wait between the first and the second announcement.
Repeat last 
announcement

Default = On.

If selected, the last announcement played to the caller is repeated until the call 
is answered or the caller hangs up.

Wait before repeat Default = 20 seconds.  Range = 0 to 9999 seconds.

If Repeat last announcement is selected, this setting is applied between each 
repeat of the last announcement.

Related links
Announcements on page 33

Recording announcements using short codes
There are no default queue announcements for user and hunt groups. The maximum length for 
announcements is 10 minutes.
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There are two default short codes that enable you to record announcements. On existing and 
upgraded systems these or similar short codes need to be added manually. The default short 
codes are:

• 91N; / N."1" / Record Message — Used to record an announcement 1. For example, to 
record announcement 1 for a hunt group on extension 300, dial *91300# and follow the 
instructions to record the new announcement.

• 92N; / N."2" / Record Message — Used to record an announcement 2. For example, to 
record announcement 2 for a hunt group on extension 300, dial *92300# and follow the 
instructions to record the announcement.

Related links
Announcements on page 33

Using pre-recorded names, greetings and announcements
It is possible to convert pre-recorded files for use as mailbox names, greetings and 
announcements.

• It can take up to 5 minutes before the system begins using a newly uploaded file.
• In all cases, if the user records a new name, greeting or announcement from their phone, the 

pre-recorded file is deleted.

The source WAV file must have the following properties:

• 8KHz Mono
• 16-bit PCM Uncompressed

Unlike greetings recorded through the embedded voicemail interface, you cannot loop pre-
recorded greetings.

Related links
User mailbox configuration on page 27
Converting pre-recorded files on page 35
Transferring Recordings to Embedded Voicemail on page 36

Converting pre-recorded files
Before you begin
The original recording must be in the following WAV file format:

• 8KHz Mono
• 16-bit PCM Uncompressed

About this task
This task converts the source WAV file recording to the format required by Embedded Voicemail.
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For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. Open IP Office Manager.

2. Select File > Advanced > LVM Greeting Utility.

3. Next to the Input File field, click the … button and select the WAV file.

4. Next to the Output File field, click the … button and select the location and file name for 
the converted file to be save to.

• This must be a directory to which you have normal file access rights. Attempting to save 
to a directory that requires administrator rights, such as the IP Office Manager program 
directory, will cause an error message to be displayed.

5. Enter a File Name and click Save. This is the name that will be entered into the 
configuration to use the recording. The file name extension must be .c11.

6. In the Output File Type field:

a. To create an auto attendant greeting file, select Auto Attendant.
b. To create a greeting file for a user extension, select one of the following:

• Announcement1 — Select for a file to be used as a user’s first announcement.

• Announcement2 — Select for a file to be used as a users second announcement.

• Greeting — Select for a file to be used as the user’s mailbox greeting. This will 
then replace the default mailbox greeting and any greeting recorded by the user.

• Name — Select for a file to be used on place of the user’s extension number in 
other mailbox prompts.

7. If you are creating an auto attendant greeting, enter a Recording Name. The name is 
case sensitive.

8. If you are creating a user greeting, in the User Extension field, enter the user's name.

9. In the Format drop-down box, select G711.

10. Click OK.

Transferring Recordings to Embedded Voicemail
About this task
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. In IP Office Manager, select File > Advanced > Embedded File Management.
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2. Drag and drop the greeting file into the System SD\SYSTEM\DYNAMIC\LVMAIL\AAG 
folder on the System SD card.

3. Wait at least 5 minutes before testing operation. The system does not start using new 
uploaded files immediately.

Other Mailbox Message Waiting Indication
By default a user only receives message waiting indication (MWI) for their own mailbox. However, 
message waiting indication for another user's mailbox or a hunt group mailbox can be configured.

Depending on the type of telephone or IP Office application they are using, users who receive 
other mailbox message waiting indication can choose any of the following methods to collect 
messages. Note that if not configured as a trusted source for another user's mailbox, the user will 
have to enter the mailbox password for that mailbox when accessing it.

• Visual Voice — On telephone that support Visual Voice, the user name is shown along with 
the number of new messages. Press the display button to access the user mailbox.

• one-X Portal for IP Office — If the one-X Portal for IP Office application is used, the other 
user name and number of new messages is displayed in the Messages gadget. Use the 
Messages gadget to access the group mailbox.

Related links
User mailbox configuration on page 27
Configuring Other User Message Waiting Indication on page 37
Configuring Hunt Group Mailbox Message Waiting Indication on page 38

Configuring Other User Message Waiting Indication
About this task
This process allows a user to be configured with message waiting indication for another user's 
mailbox.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. Click User and select the individual user.

3. Select the Source Numbers tab.

4. Click Add.

5. In the Source Number field, enter U followed by the user name or extension. For example 
enter U201.

6. Click OK.

7. Save the configuration back to the system (File > Save Configuration).
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Related links
Other Mailbox Message Waiting Indication on page 37

Configuring Hunt Group Mailbox Message Waiting Indication
About this task
This process can be used to give a user message waiting indication for a hunt group's mailbox.
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click User and select the required user.

3. Click the Source Numbers tab.

4. Click Add.

5. In the Source Number field, enter H followed by the name of the hunt group. For example, 
for the hunt group Main, enter HMain.

6. Click OK.

7. Repeats steps 3 through 7 for any other hunt groups for which the user requires message 
waiting indication.

8. Save the configuration back to the system (File > Save Configuration).

Related links
Other Mailbox Message Waiting Indication on page 37

Editing a User's Trusted Locations
About this task
If a user regularly accesses their mailbox from another extension or from a number that presents 
a CLI, such as a mobile or home number, that location can be set a trusted location. In that case, 
the user is no longer prompted to enter their password.
By default a user's own extension is already configured as a trusted location. That setting should 
be removed if the mailbox should always prompt the user for their password.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. Click User and select the individual user.

3. Select the Source Numbers tab.
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4. Add or delete the source numbers prefixed with a V. These numbers are used as follows:

• User's own extension number — For example, a user whose extension number is 214 
wants to be able to access voicemail messages without entering the voicemail code. A 
source number V214 would be entered.

• Other user extension numbers — For example, a user whose extension is 214 wants 
to be able to access voicemail messages from extension 204. A source number V204 
would be entered. From then on when the user of extension 214 dials a short code from 
extension 204, system will not prompt the user for the voicemail code.

• External telephone numbers — Add a V source number containing the external 
telephone number. For example, V01923 38383 would be entered if the external number 
was 01923 38383. When users dial the number set up as the Incoming Call Route to 
Voicemail from the "trusted location", they will not be prompted for their mailbox number 
or Voicemail Code.

5. Click OK.

6. Save the configuration back to the system (File > Save Configuration).

Related links
User mailbox configuration on page 27

Visual Voice
A user can be provided a display menu to use for access to their mailbox. The menu provides 
the user with options to listen to messages, send messages, and change their greetings and 
password.

Configuring a Visual Voice button
About this task
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.
The Visual Voice feature is not available on all telephones. It requires an Avaya telephone with a 
multi-line (more than two) display.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click User and select the required user.

3. Click the Button Programming tab.

4. Click the button line that you want to change.

5. Right-click in the Action field.

Visual Voice
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6. Select Emulation > Visual Voice.

7. Click OK.

8. Repeat this procedure for other users as required.

9. Save the configuration back to the system (File > Save Configuration).

Configuring the MESSAGES button
About this task
You can configure the MESSAGES button to activate Visual Voice rather than access the spoken 
voicemail prompts.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click System.

3. Select Voicemail.
4. Click the Messages Button Goes To Visual Voice check box to select this option.

5. Click OK.

6. Save the configuration back to the system (File > Save Configuration).
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Chapter 4: Hunt group mailbox 
configuration

Embedded voicemail creates a mailbox for each hunt group on the system. Calls are sent to the 
mailbox when voicemail is set as the group's fallback destination and they have exceeded the 
group’s no answer time.

This chapter describes how to configure the group mailbox through the hunt group settings in IP 
Office Manager. A group mailbox can also be configured through the mailbox and system short 
codes (see the IP Office Embedded Voicemail User Guide for more information).

Hunt group mailbox features include:

• Message Waiting Indication – By default there is no message waiting indication to any user 
for hunt group messages. Users must be configured individually. For more information, see 
Configuring Message Waiting Indication on page 38.

• Mailbox access – By default there is no mailbox access to hunt group mailboxes to collect 
messages. Users assigned hunt group message waiting indication may also gain access 
depending on their phone type. Otherwise an access short code must be created for the hunt 
group. For more information, see Hunt group mailbox access on page 45.

• Ringback – Embedded voicemail can be set to ring the user whenever they have new 
messages in a hunt group mailbox for which they receive message waiting indication. This 
ringback is triggered after the completion of a call at the user's extension.

• Voicemail on or off – Sending calls to the group's mailbox can be switched off. Note however 
that this does not stop other methods of leaving messages directly in the mailbox.

• Access code – An access code can be assigned to the mailbox. Anyone accessing the 
mailbox must first enter this code before they can collect messages. The access code can be 
reset by the user once they are in the mailbox.

Related links
Configuring a group mailbox on page 42
Hunt Group Message Waiting Indication on page 44
Hunt group mailbox access on page 45
Announcements on page 47
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Configuring a group mailbox
About this task
Calls are sent to the mailbox when voicemail is set as the group's fallback destination and they 
have exceeded the group’s no answer time.

Caution:
Mailboxes are created based on the unique group name within the IP Office configuration. 
Changing a group's name associates that group with a new mailbox. If it is necessary to 
change a group name, ensure that users have played and deleted all group messages first. If 
a group name is changed without clearing the original mailbox, you must create a short code 
based on the old group name in order to access the old mailbox.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click Group and select the required group.

3. Click on the Fallback tab.

a. Set the Group No Answer Time to the required number of seconds after which 
unanswered calls should be redirected to the group's no answer destination.

b. Set the Group No Answer Destination to Voicemail.
4. Click the Voicemail tab.

5. Change the fields as appropriate. See Hunt Group Voicemail Settings on page 43 for 
more information.

6. Click OK.

7. Repeat the steps for each hunt group as required.

8. Save the configuration back to the system (File > Save Configuration).

Related links
Hunt group mailbox configuration on page 41
Hunt Group Fallback Settings on page 42
Hunt Group Voicemail Settings on page 43

Hunt Group Fallback Settings
Path: Group > Fallback
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Name Description
Group No Answer Time Default = 45 seconds, Range = 1 to 99999 seconds.

This setting sets how long a call should be presented to a hunt group, 
and its overflow groups, if set, before going to the group's Group No 
Answer Destination. When exceeded, the call is redirected regardless of any 
announcements, overflow or queuing. If set to Off, the no answer destination is 
used once each available member of the hunt group has been alerted for the 
group's No Answer Time.

Group No Answer 
Destination

This destination is used when the Group No Answer Time is reached. The 
options are:

• <NONE> - The destination is not used. Instead calls continue ringing against 
the hunt group.

• Voicemail - The call is redirected to voicemail to leave a message. Note that 
the mailbox of the call's original destination is used.

• The drop-down list includes all other group and user extensions. The call is 
redirected to that extension.

• A number can be manually entered. This is used for matching against system 
short codes.

Related links
Configuring a group mailbox on page 42

Hunt Group Voicemail Settings
Path: Group > Voicemail

Name Description
Voicemail Code Default = Blank, Range = 0 (no code) to 15 digits.

This field sets the mailbox access code. This code is required for access to the 
mailbox from any source that is not a trusted location.

If remote access is attempted to a mailbox that has no voicemail code set, the 
prompt, “Remote access is not configured on this mailbox” is played.

If password enforcement has been enabled for the system, the voicemail code 
cannot:

• be the same as the extension number

• be the same as the previous code

• contain any consecutive digits

• contain repeated digits

• be shorter than the system’s minimum password length setting

Table continues…
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Name Description
Voicemail Email Default = Blank (No voicemail email features).

This field is used to set the user or group email address used for voicemail 
email operation. When an address is entered, additional Voicemail Email 
controls described below are selectable.

Voicemail Email Default = Off.

If an email address is entered for the user or group, the following options 
become selectable. These options control the mode of automatic voicemail 
email operation provided by the voicemail server whenever the voicemail 
mailbox receives a new voicemail message.

• Off — If select, voicemail email is not used. Users can select this mode by 
dialing *03 from their extension.

• Copy — If selected, each time a new voicemail message is received in 
the voicemail mailbox, a copy of the message is attached to an email and 
sent to the email address. There is no mailbox synchronization between 
the email and voicemail mailboxes. For example, reading and deleting the 
email message does not affect the message in the voicemail mailbox or the 
message waiting indication provided for that new message.

• Forward — If selected, each time a new voicemail message is received 
in the voicemail mailbox, that message is attached to an email and sent 
to the email address. No copy of the voicemail message is retained in the 
voicemail mailbox and their is no message waiting indication. Like the Copy 
option, there is no mailbox synchronization between the email and voicemail 
mailboxes. Users can select this mode by dialing *01 from their extension.

• Alert — If selected, each time a new voicemail message is received in the 
voicemail mailbox, a simple email message is sent to the email address. This 
is an email message announcing details of the voicemail message but with 
no copy of the voicemail message attached. Users can select this mode by 
dialing *02 from their extension.

Voicemail Help Default = Off.

Help can also be accessed by dialing *4 after accessing the mailbox.
Broadcast This setting is not used for embedded voicemail.
UMS Web Services This setting is not used for embedded voicemail.

Related links
Configuring a group mailbox on page 42

Hunt Group Message Waiting Indication
By default, no message waiting indication is sent to any user for a hunt group mailbox. The 
following task shows how to give a user message waiting indication from a hunt group's mailbox. 
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The method of indication will depend on the type of telephone the user has and whether they are 
using any IP Office application.

• Voicemail Ringback — If a user has voicemail ringback enabled, ringback will occur for new 
group messages as well as new personal messages. Ringback for personal messages takes 
place before any ringback for new group messages.

• Visual Voice — If available, the user will see the name of the hunt group listed. The number 
of new calls are shown in brackets next to the hunt group name.

Related links
Hunt group mailbox configuration on page 41

Configuring Hunt Group Mailbox Message Waiting Indication
About this task
This process can be used to give a user message waiting indication for a hunt group's mailbox.
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click User and select the required user.

3. Click the Source Numbers tab.

4. Click Add.

5. In the Source Number field, enter H followed by the name of the hunt group. For example, 
for the hunt group Main, enter HMain.

6. Click OK.

7. Repeats steps 3 through 7 for any other hunt groups for which the user requires message 
waiting indication.

8. Save the configuration back to the system (File > Save Configuration).

Related links
Other Mailbox Message Waiting Indication on page 37

Hunt group mailbox access
By default, no user has access to a hunt group mailbox until specifically configured for such 
access. Hunt group mailboxes can be accessed using the following methods:

• Message Waiting Indication access
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• Short code and button access

• Remote access

Related links
Hunt group mailbox configuration on page 41
Message Waiting Indication access methods on page 46
Short code and button access on page 46
Remote access on page 47

Message Waiting Indication access methods
Users who have been assigned hunt group message waiting indication are also given methods to 
access the hunt group mailbox. The method depends on what type of telephone or software the 
user has.

Voicemail ringback
If a user has voicemail ringback enabled, ringback will occur for new group messages as well as 
new personal messages. Ringback for personal messages takes place before any ringback for 
new group messages.

Visual Voice
If Visual Voice is available, the user will see the name of the hunt group listed. The number of new 
calls are shown in brackets next to the hunt group name.

Related links
Hunt group mailbox access on page 45

Short code and button access
A short code can be created for hunt group mailbox access, as shown in the following table. This 
can be a system-wide or user-specific short code. For information about setting up short codes, 
see the IP Office Manager on-line help or user guide.

Field Contains…
Code *99
Feature Voicemail Collect
Telephone Number “?Sales”
Line Group ID 0

The Voicemail Collect feature and hunt group mailbox name can also be assigned to a user's 
programmable button.

Related links
Hunt group mailbox access on page 45
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Remote access
The standard methods for remote mailbox access apply to users or to hunt groups. See Remote 
mailbox access on page 66 for more information.

Related links
Hunt group mailbox access on page 45

Announcements
Announcements are played to callers waiting to be answered. For a hunt group, this includes both 
callers ringing at an agent and still queued.  

• If no voicemail channel is available for an announcement, the announcement is not played.

• Calls can be answered during the announcement.

• If a call is rerouted to a hunt group's Night Service Destination or Out of Service 
Destination, the announcements settings of the new destination are applied.  

• If a call overflows, the announcements of the original group are still applied, not those of the 
overflow group.

• For announcements configured for hunt groups to be used effectively, the hunt group's 
Group No Answer Time must be extended.

• For announcements configured for users to be used effectively, the user's No Answer Time 
must be extended or Voicemail On must be unselected.

Related links
Hunt group mailbox configuration on page 41
Configuring announcements on page 47
Recording announcements using short codes on page 49

Configuring announcements
Procedure

1. Using IP Office Manager, receive the configuration from the system.

2. In the left navigation pane, do one of the following:

• To configure an announcement for a user, click User.
• To configure an announcement for a hunt group, click Group.

3. Click the Announcements tab.

4. Set the fields to the appropriate values. See Group Announcement settings on page 48
for more information.

5. Click OK.
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6. Save the configuration back to the system (File > Save Configuration).

Related links
Announcements on page 47

Group Announcement settings
Path: Group > Announcements

Name Description
Announcements On Default = Off.

This setting enables or disables announcements.
Wait before 1st 
announcement

Default = 10 seconds. Range = 0 to 9999 seconds.

This setting sets the time delay from the calls presentation, after which the first 
announcement should be played to the caller. If Synchronize calls is selected, 
the actual wait may differ.

Flag call as answered Default = Off.

This setting is not currently used.
Post announcement 
tone

Default = Music on hold.

Following the first announcement, you can select whether the caller should 
hear music on hold, ringing, silence until answered, or hear another 
announcement.

2nd Announcement Default = On.

If selected, a second announcement can be played to the caller if they have 
still not been answered.

Wait before 2nd 
announcement

Default = 20 seconds. Range = 0 to 9999 seconds.

This setting sets the wait between the first and the second announcement. If 
Synchronize calls is selected, the actual wait may differ.

Repeat last 
announcement

Default = On.

If selected, the last announcement played to the caller is repeated until the call 
is answered or the caller hangs up.

Wait before repeat Default = 20 seconds.  Range = 0 to 9999 seconds.

If Repeat last announcement is selected, this setting is applied between each 
repeat of the last announcement. If Synchronize calls is selected, this value is 
grayed out and set to match the Wait before 2nd announcement setting.

Table continues…
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Name Description
Synchronize calls Default = Off.

This option is only available for hunt group announcements. It can be 
used to restrict how many voicemail channels are required to provide the 
announcements.

• Off – Announcements are played individually for each call. This requires a 
separate voicemail channel each time an announcement is played to each 
caller. While this ensures accurate following of the wait settings selected, it 
does not make efficient use of voicemail channels.

• On – If a required announcement is already being played to another caller, 
subsequent callers wait until the announcement has been completed and can 
be restarted. In addition, when a caller has waited for the set wait period 
and the announcement is started, any other callers waiting for the same 
announcement, hear it even if they have not waited for the wait period. 
Using this setting, the number of voicemail channels needed for the groups 
announcements is minimized..

Recording announcements using short codes
There are no default queue announcements for user and hunt groups. The maximum length for 
announcements is 10 minutes.

There are two default short codes that enable you to record announcements. On existing and 
upgraded systems these or similar short codes need to be added manually. The default short 
codes are:

• 91N; / N."1" / Record Message — Used to record an announcement 1. For example, to 
record announcement 1 for a hunt group on extension 300, dial *91300# and follow the 
instructions to record the new announcement.

• 92N; / N."2" / Record Message — Used to record an announcement 2. For example, to 
record announcement 2 for a hunt group on extension 300, dial *92300# and follow the 
instructions to record the announcement.

Related links
Announcements on page 47
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Chapter 5: Auto attendant configuration

In addition to basic voicemail operation, embedded voicemail supports auto attendant services. Up 
to 40 auto attendants are supported.

Each auto attendant consists of:

• Actions – Each of the normal DTMF dialing keys; *, # and 0 to 9, can be assigned to an action. 
Callers can dial through prompts, that is, press an action key while listening to the greeting 
prompts. You can also assign an action for the detection of fax tone.

• Prompts - Separate morning, afternoon and evening (out of hours) greeting prompts can be 
recorded. Which prompt is used is defined by associated time profiles. The greeting prompt 
is followed by a menu options prompt. This is used to inform the caller of the auto attendant 
options. For more information, see Prompt recordings on page 55. In situations where time 
profiles are absent, overlap, or conflict; the order of precedence is given to time profiles 
assigned to Morning, Afternoon, and then Evening.

Related links
Creating an auto attendant on page 50
Recording Prompts on page 55
Routing incoming calls to an auto attendant on page 57
Transferring calls to an auto attendant on page 58
Using an auto attendant to access voicemail on page 60
Dial By Name on page 61
Recording Caller Consent on page 62
Using pre-recorded names, greetings and announcements on page 63

Creating an auto attendant
About this task
This task is an example to setup an auto attendant for Embedded Voicemail. In this context, the 
auto-attendant must provide callers the option to press 0 for reception that is hunt group 200 or 1 
for sales that is hunt group 301.

Procedure
1. Using IP Office Manager, receive the configuration from the system.
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2. In the left navigation pane, right-click Auto Attendant and select New.

3. In the Auto Attendant tab, complete the fields as appropriate. See Auto Attendant tab field 
descriptions on page 51 for more information.

4. Click the Actions tab to define the actions available to callers depending on which DTMF 
key they press. Then do the following:

a. To define the auto attendant action when the 0 key is pressed, click the row that 
begins with 0.

b. Click Edit.
c. In the Action drop-down box, select the appropriate action.

d. In the Destination drop-down box, select the appropriate destination.

e. Click OK.

f. Repeat the steps above for each key that requires a definition for this auto attendant.

5. Click OK.

6. Note the short codes shown in the Auto Attendant tab.

7. Save the configuration back to the system (File > Save Configuration).

8. To record prompts for the auto attendant using the short codes created, see Prompt 
recordings on page 55.

Related links
Auto attendant configuration on page 50
Auto Attendant General Settings on page 51
Auto-Attendant Action Settings on page 52

Auto Attendant General Settings
Name Description
Name Range = Up to 12 characters.

This field sets the name for the auto-attendant service. External calls can be 
routed to the auto attendant by entering AA:Name in the destination field of an 
Incoming Call Route.

Maximum Inactivity Default = 8 seconds; Range = 1 to 20 seconds

This field sets how long after playing the prompts the Auto Attendant should 
wait for a valid key press. If exceeded, the caller is either transferred to the 
Fallback Extension set within the Incoming Call Route used for their call or else 
the caller is disconnected.

Enable Local 
Recording

Default = On

When off, use of short codes to record auto-attendant prompts is blocked. The 
short codes can still be used to playback the greetings.

Table continues…
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Name Description
Direct Dial-By-Number Default = Off

This setting affects the operation of any key presses in the auto attendant 
menu set to use the Dial By Number action.

• If selected, the key press for the action is included in any following digits 
dialed by the caller for extension matching. For example, if 2 is set in the 
actions to Dial by Number, a caller can dial 201 for extension 201.

• If not selected, the key press for the action is not included in any following 
digits dialed by the caller for extension matching. For example, if 2 is set in 
the actions to Dial by Number, a caller must dial 2 and then 201 for extension 
201.

Dial By Name Match 
Order

Default = First Name/Last Name

Determines the name order used for the Dial by Name function. The options 
are First then last or Last then first.

AA NumberAA Number This number is assigned by IP Office and cannot be changed. It is used in 
conjunction with short codes to access the auto attendant service or to record 
auto attendant greetings.

Morning/Afternoon/
Evening/Menu Option  

Each auto-attendant can consist of three distinct time periods, defined by 
associated time profiles. A greeting can be recorded for each period. The 
appropriate greeting is played to callers and followed by the Menu Options 
greeting which should list the available actions.

Time Profile The time profile that defines each period of auto attendant operation. When 
there are overlaps or gaps between time profiles, precedence is given in the 
order morning, afternoon and then evening.

ShortcodeShort code These fields indicate the system short codes automatically created to allow 
recording of the time profile greetings and the menu options prompt.

Recording Name Default = Blank; Range = Up to 31 characters.

This field appears next to the short code used for manually recording auto 
attendant prompts. It is only used if using pre-recorded .wav files as greetings 
rather than manually recording greetings using the indicated short codes. If 
used, note that the field is case sensitive and uses the name in the file header 
that is embedded within the .wav file rather than the actual file name.

The utility for converting .wav files to the correct format is provided with 
Manager and can be launched via File > Advanced > LVM Greeting Utility. 
Files then need to be manually transferred to the memory card.

Related links
Creating an auto attendant on page 50

Auto-Attendant Action Settings
Each of the normal DTMF dialing keys; *, # and 0 to 9, can be assigned to an action. Callers can 
dial-through prompts, that is press an action key while listening to the greetings prompts. You can 
also assign an action to the key Fax to automatically reroute calls where fax tone is detected.
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Action Description
Centrex Transfer If the auto attendant is being used to answer incoming calls from a Centrex 

exchange, this option can be used to perform a Centrex transfer. When select 
by the caller, the IP Office sends a flash hook signal to the exchange using the 
same line as the incoming call, dials the configured destination numbers and 
then disconnects itself from the call.

This only applies to Centrex analog trunks hosted by the same system as the 
auto-attendant.

Dial By Name Callers can dial the name of the user they require. A list of matching names is 
then played to them to make a selection.

Dial By Number Callers can dial the required extension number. There is no prompt associated 
with the action. If a prompt is required it as part of the menu prompt. 
Unexpected results can occur if the dial plan is not a uniform length. Hunt 
group and user extension numbers should all be the same length.

Normal Transfer Transfers the caller to a specified number. This is a supervised transfer, that is, 
if busy or unanswered the call will follow the settings of the target user or hunt 
group. If the destination field is left blank, callers can dial the extension number 
that they require, however no prompts will be played.

Not Defined Take no action.

Table continues…
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Action Description
Park and Page This option parks the caller and then performs a page to the set destination 

to announce the parked call. When selected, the following additional fields are 
configurable. Note: Calls parked using this feature use a voicemail channel 
whilst parked and also an additional channel during the page.

• Park Slot Prefix — The park slot number prefix of up to 8 digits. When the 
system parks a call, it use the prefix plus an additional digit, 0 to 9, for each 
call it has parked. The full park slot number is announced as part of the page.

- If the Park Slot Prefix plus addition digit (0 to 9) falls within the 
range configured for the manual park and page feature ( > System > 
Telephony > Park and Page > Central Park Range), then calls parked 
by embedded voicemail can be unparked by simply dialing the park slot 
number.

- • Any Call Park buttons configured to a park slot number used by the 
embedded voicemail will indicated when there is a parked call and can be 
used to unpark the call.

• Paging Number – This is the number which the system will page to 
announce the parked call. It does so using the recorded Page Prompt (see 
below) followed by then announcing the park slot number used.

• Retry Count – Sets the number of times that the system repeats the parked 
call announcement, up to a maximum of 5 times.

• Fallback Number – The parked call is transferred to this number if it is still 
unanswered 1 minute after the last page. Calls are also transferred to this 
number if the system cannot park the call for any reason.

• Retry Timeout – Sets the delay in minutes and seconds between paging 
repeats. The range can be set in 15-second increments. The minimum 
setting is 15 seconds (the default) and the maximum setting is 5 minutes.

• Page Prompt – The prompt used for the page can either be recorded 
manually or using a pre-recorded file. In both cases, the page is 
automatically followed by an announcement of the park slot number used.

Replay Menu Greeting Replay the menu greeting that lists the menu actions.
Transfer Transfer the caller to the selected destination. For the key option Fax, this 

action should be used to set the destination for incoming fax calls.
Transfer to Auto 
Attendant

Transfer the caller to another auto attendant.

Setting Description
Destination For actions that redirect the caller, the destination can be entered manually or 

selected from the drop-down list.
Consent Directive If required, the caller’s consent or dissent to a prompted choice can be 

recorded. This choice is included in the call records output by the system. 
See Recording Caller Consent on page 62.
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Related links
Creating an auto attendant on page 50

Recording Prompts
When a new auto attendant is created, a number of short codes are automatically added to the 
system short codes table. The short codes allow the recording of the various auto attendant 
prompts. The appropriate number to dial is indicated against each greeting on the They are 
Auto Attendant tab in IP Office Manager. *81XX, *82XX, *83XX and *84XX. These short codes 
allow the recording of the various auto attendant prompts by replacing the XX part with the 
auto-attendant number when dialing.

The telephone number part takes the form AA: Name.x , where Name is the name of the auto 
attendant service, and x is 1 for the morning greeting, 2 for the afternoon greeting, 3 for the 
evening greeting, and 4 for the menu options prompt.

The number can also take the form AA: N.x where N is the auto attendant number and x is 1 for 
the morning greeting, 2 for the afternoon greeting, 3 for the evening greeting and 4 for the menu 
options prompt.

• *81XX is used to hear and record the morning greeting for an auto-attendant.

• *82XX is used to hear and record the afternoon greeting for an auto-attendant.

• *83XX is used to hear and record the evening greeting for an auto-attendant.

• *84XX is used to hear and record the actions menu prompt for an auto-attendant.

• The appropriate number to dial for each greeting is shown on the Auto Attendant tab in IP 
Office Manager.

When using any of these short codes, you hear the options:

• 1 to hear the current prompt.

• 2 to record a new prompt.

• 3 to save the new prompt.

Note:
• To prevent abuse of these default short codes, they can be deleted or changed. They can 

also be removed from the system short codes section and rebuilt in the user short codes 
of a trusted user. Alternately, disabling the Enabling Local Recording option stops the use 
of short codes to record the auto attendant greetings.

• Using the Dial feature, the short codes can be assigned to a programmable button. This 
allows quick access and recording of any prompts that change frequently.

• 1 to hear the current prompt.

• 2 to record a new prompt.
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• 3 to save the new prompt.

Page and Page Short Codes
A number of system short codes also exist for recording the prompts for Park and Page actions. 
The short codes depend on the key (0 to 9, *. #) to which the action has been assigned and the 
number of the auto-attendant. The short codes allow the recording prompt by replacing the XX part 
with the auto-attendant number when dialing.

• *800XX is used for Park and Page actions assigned to the 0 key.

• ...
• *809XX is used for Park and Page actions assigned to the 9 key.

• *850XX is used for Park and Page actions assigned to the * key.

• *851XX is used for Park and Page actions assigned to the # key.

Controlling Short Code Use
To prevent abuse of the default short codes, they can be deleted or changed. They can also be 
removed from the system short codes section and rebuilt in the user short codes of a trusted 
user(s). 
Alternatively, disabling the Enabling Local Recording option in an auto-attendant's settings stops 
the use of short codes to record the auto attendant's prompts and greetings.

Creating Auto Attendant Short Codes
In order to create custom short codes for recording prompts, use the Auto Attendant feature. The 
Telephone Number field of the short code can take two forms:

• Auto-Attendant Greeting and Menu Action Prompts:
- The Telephone Number can take the form "AA:"N".X" where N is the auto attendant 

number and X is 1 for the morning greeting, 2 for the afternoon greeting, 3 for the evening 
greeting and 4 for the menu options prompt.

- The Telephone Number can take the form "AA:Name.X", where Name is the name 
of the auto attendant service, and X is 1 for the morning greeting, 2 for the afternoon 
greeting, 3 for the evening greeting, and 4 for the menu options prompt.

- In both the above, you can omit the .X to create a short code for calls to the auto-
attendant.

• Park and Page Action Prompts:
- The Telephone Number takes the form "AA:"N".YY" where N is the auto attendant 

number and YY is a two-digit representation of the key to which the action has been 
assigned. That is, 00 for the 0 key, 01 for the 1 key, …, 09 for the 9, 10 for the * key and 
11 for the # key.

Related links
Auto attendant configuration on page 50
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Routing incoming calls to an auto attendant
About this task
You can specify an auto attendant as a destination in the IP Office Incoming Call Routes table. 
Internal callers can access an auto attendant through a programmed DSS button or Phone 
Manager speed dial.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the left navigation pane, click Incoming Call Route.

3. Select the appropriate route.

4. Click the Standard tab and confirm that the settings match the calls you expect to be 
routed to the auto attendant.

For more information, see the IP Office Manager on-line help.

5. Click the Destination tab.

6. In the Destination drop-down box, select the auto attendant.

The names of the configured auto attendants are shown prefixed with AA:. 

In this example, the Fallback Extension has also been set to route calls to a hunt group. 
The Fallback Extension setting is used for callers in the auto attendant who do not make a 
valid key press within the auto attendant's Maximum Inactivity time.

Using time profiles, you can add additional destination sets to use the auto attendant at 
certain times of day or to use different auto attendants at different times.

7. Click OK.

8. Save the configuration back to the system (File > Save Configuration).

Related links
Auto attendant configuration on page 50
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Transferring calls to an auto attendant
Normally calls are directed to an auto attendant by an incoming call route. However, it can also be 
useful to transfer calls received at an internal extension to an auto attendant.

Related links
Auto attendant configuration on page 50
Short codes on page 59

Programmed buttons
Avaya telephones with programmable buttons can be programmed to access auto attendant 
services.

Creating an auto attendant button
About this task
Use this procedure to set up a programmed button so that a user can use the button to transfer 
calls to the auto attendant.

Procedure
1. From the IP Office system configuration, set the action of one of the user's programmable 

buttons to Dial.
2. Set the associated telephone number to AA:Name where Name matches the name of the 

auto attendant.

3. Select File > Save Configuration to save the changes back to the system.

Transferring a call using a programmed button
Procedure

1. Place the call on hold.

2. Press the button programmed for the auto attendant.

3. Hang up the call at their extension.

A blind transfer of the held call to the auto attendant occurs.

SoftConsole
SoftConsole is an application intended for telephone system operators or receptionists. It displays 
details of calls and allows the system operators or receptionists to quickly see the status of the 
callers required destination and transfer the call.

Creating a SoftConsole auto attendant speed dial
Procedure

1. Click the required BLF Group tab.
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2. Right-click the speed dial panel and select New > BLF Group Member.
3. In the Name field, enter a name for the auto attendant.

4. In the Number field, enter AA:Name where Name matches the name of the auto 
attendant.

5. Click OK.

Transferring a SoftConsole call using speed dial
Procedure

1. During a call that you want to transfer to the auto attendant, click Hold to place the call on 
hold.

2. Click the BLF Group tab.

3. Click the speed dial created for the auto attendant.

4. Click Complete Transfer to transfer the held caller.

Short codes
The Auto Attendant short code feature can be used to connect to a particular auto attendant. The 
Telephone Number field takes the form AA: followed by the auto attendant service name.

Once a short code for a particular auto attendant has been created, callers can be transferred.

Example
In this example, dialing *98 connects the user with the auto attendant named Example.

Field Contains…
Code *98
Feature Auto Attendant
Telephone Number “AA:Example”
Line Group ID 0

Related links
Transferring calls to an auto attendant on page 58
Transferring calls using short codes on page 59

Transferring calls using short codes
Procedure

1. Press TRANSFER.

2. Dial the auto attendant short code.

3. Press TRANSFER again to complete the process.

Related links
Short codes on page 59
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Using an auto attendant to access voicemail
About this task
A useful function in auto attendants is to let callers access their own voicemail mailbox. This can 
be achieved by first creating a short code and then using the short code as an auto attendant 
destination. Use this procedure to create a short code for remote access.
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. Do one of the following:

• To create remote access for a user, in the left navigation pane, click User and then 
select the appropriate user.

• To create remote access for a hunt group, in the left navigation pane, click Group and 
then select the appropriate hunt group.

3. Click the Voicemail tab.

4. Ensure that a Voicemail Code has been set. Remote access cannot work without a 
voicemail code.

5. In the left navigation pane, right-click Shortcode and select New.

6. Create a short code as in the following example:

Field Contains…
Code *99
Feature Voicemail Collect
Telephone Number ?
Line Group ID 0

7. Click OK.

8. Create an auto attendant and select the key that the caller should use. See Creating an 
auto attendant on page 50 for more information.

a. Set the Action to Normal Transfer.
b. In the Destination drop-down box, type the short code.

Following the example shown in step 6, type *99.

9. Click OK.

10. Save the configuration back to the system (File > Save Configuration).

Related links
Auto attendant configuration on page 50
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Dial By Name
The Dial By Name feature can be selected as an auto attendant option. Callers selecting this 
option are asked to dial the name they require and then press #. The recording name prompts of 
matching users are then used to allow the caller to make their selection.

The name order (First then last or Last then first is set by the Dial By Name Match Order 
setting in the auto attendant on the Auto Attendant tab.

The name used for matching is taken from the user's configuration within the IP Office 
configuration. The Full Name is used if set, otherwise the Name is used.

Users are excluded from Dial By Name if they:

• Are marked as Ex Directory (User > User) in the IP Office configuration.

• Do not have a recorded mailbox name prompt. They can record their own name by dialing 
*05 after accessing their mailbox.

The Dial By Name feature assumes that a standard ITU lettered dialing pad is being used.

How Dial By Name works
1. The caller gets a prompt to dial the name they require and then press #.

For example, dialing 527 matches names starting with JAS (for example “Jason”) and KAR 
(for example “Karl”).
Callers can also press *# to exit without making a selection.

2. If no matches are found, the caller is given the option to retry.
3. If 10 or less matches are found, the matching mailbox name greetings are played as part 

of a selection list.
For example, “Press 1 for …”, “Press 2 for …”, “Press 3 for …”, etc.

4. If more then 10 matches are found, the caller is prompted to either press # to hear the first 
10 matches or to dial more characters to reduce the number of matches. If they select to 
play the list, after each set of 10 matches they can either make a selection or follow the 
prompts for other options.

Related links
Auto attendant configuration on page 50
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Recording Caller Consent
In some scenarios, you may want to prompt the user as to whether they consent to an action or 
requirement. It may also be a requirement to keep a record of the caller's consent.
When using embedded voicemail, this can be done using the Consent Directive settings of each 
auto-attendant action. These cause a consent value to be included in the system's SMDR output 
for the call (0 = consent not requested, 2 = consent given, 6 = consent denied). The consent value 
is also included in available to the system's DevLink3 CTI output.

Example
The customer has a sales group. If the group is busy, they want to give callers the chance to leave 
their address details and have someone get in touch later. However, local laws require them also 
log that the caller consented to the company having a record of caller's address information.

1. In the system configuration, they have setup 2 sales groups with the same members:
a. One group is configured with voicemail enabled to answer calls if no agent answers in 

a reasonable time. That mailbox prompts the caller to leave their contact information 
and an agent will contact them.

b. The other group is configured with voicemail disabled.
2. An auto-attendant has been created for the sales team calls. The menu actions prompt 

informs callers “If you are okay with us recording your address and contact details if any 
agent cannot answer immediately, press 1 and we will contact you. If otherwise, press 0. 
Note however that we may have to drop calls if our agents are all busy.”

3. The two actions, keys 0 and 1, have been configured to transfer to the caller to the 
appropriately configured groups.

4. The incoming call route for sales calls has its Destination set to AA:Sales.

Auto attendant configuration
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Related links
Auto attendant configuration on page 50

Using pre-recorded names, greetings and announcements
It is possible to convert pre-recorded files for use as mailbox names, greetings and 
announcements.

• It can take up to 5 minutes before the system begins using a newly uploaded file.

• In all cases, if the user records a new name, greeting or announcement from their phone, the 
pre-recorded file is deleted.

The source WAV file must have the following properties:

• 8KHz Mono

• 16-bit PCM Uncompressed

Unlike greetings recorded through the embedded voicemail interface, you cannot loop pre-
recorded greetings.

Related links
Auto attendant configuration on page 50
Converting pre-recorded files on page 63
Transferring Recordings to Embedded Voicemail on page 64
Configuring an Auto Attendant to use a greeting file on page 65

Converting pre-recorded files
Before you begin
The original recording must be in the following WAV file format:

• 8KHz Mono
• 16-bit PCM Uncompressed

About this task
This task converts the source WAV file recording to the format required by Embedded Voicemail.
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. Open IP Office Manager.

2. Select File > Advanced > LVM Greeting Utility.

Using pre-recorded names, greetings and announcements
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3. Next to the Input File field, click the … button and select the WAV file.

4. Next to the Output File field, click the … button and select the location and file name for 
the converted file to be save to.

• This must be a directory to which you have normal file access rights. Attempting to save 
to a directory that requires administrator rights, such as the IP Office Manager program 
directory, will cause an error message to be displayed.

5. Enter a File Name and click Save. This is the name that will be entered into the 
configuration to use the recording. The file name extension must be .c11.

6. In the Output File Type field:

a. To create an auto attendant greeting file, select Auto Attendant.
b. To create a greeting file for a user extension, select one of the following:

• Announcement1 — Select for a file to be used as a user’s first announcement.

• Announcement2 — Select for a file to be used as a users second announcement.

• Greeting — Select for a file to be used as the user’s mailbox greeting. This will 
then replace the default mailbox greeting and any greeting recorded by the user.

• Name — Select for a file to be used on place of the user’s extension number in 
other mailbox prompts.

7. If you are creating an auto attendant greeting, enter a Recording Name. The name is 
case sensitive.

8. If you are creating a user greeting, in the User Extension field, enter the user's name.

9. In the Format drop-down box, select G711.

10. Click OK.

Related links
Using pre-recorded names, greetings and announcements on page 63

Transferring Recordings to Embedded Voicemail
About this task
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. In IP Office Manager, select File > Advanced > Embedded File Management.
2. Drag and drop the greeting file into the System SD\SYSTEM\DYNAMIC\LVMAIL\AAG 

folder on the System SD card.

3. Wait at least 5 minutes before testing operation. The system does not start using new 
uploaded files immediately.
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Related links
Using pre-recorded names, greetings and announcements on page 63

Configuring an Auto Attendant to use a greeting file
About this task
The same greeting file can be used by multiple auto attendants.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. Select the Auto Attendant form and select or create the required auto attendant.

3. In the Recording Name field, enter the name of the greeting to be used.

This is the Recording Name entered during the file conversion, not the actual file name. 
The name is case sensitive.

4. Once uploaded to the IP Office, the converted files can still be recorded over using the 
default short codes for recording auto attendant greetings. To prevent this use, deselect 
the Enable Local Recording option of the auto attendant.

5. Click OK.

6. Save the configuration back to the system (File > Save Configuration).

Related links
Using pre-recorded names, greetings and announcements on page 63
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Chapter 6: Miscellaneous

This section covers general aspects of embedded voicemail operation.

Related links
Remote mailbox access on page 66
Mailbox Password Rules on page 67
Configuring buttons on page 68
Short Codes on page 69

Remote mailbox access
Remote mailbox access is accessing a mailbox from any location that does not match the mailbox 
user's or hunt group's number. That includes both internal and external access.

Remote access is possible only if the mailbox user or hunt group has a voicemail code set in the 
IP Office configuration.

You can enable remote mailbox access using any of the following methods:

• Direct from an incoming call route

• Using a short code

• Via an auto attendant

Direct from an incoming call route
An incoming call route can be configured to enable remote access to a mailbox. The option 
Voicemail can be selected as the Destination and/or Night Service Destination of an Incoming 
Call Route.

Using a short code
A short code can be created that uses the Voicemail Collect feature but without a mailbox name 
specified in the Telephone Number field. An example is shown below. This short code could be 
utilized by users on the system as the destination in an Incoming Call Route or as the destination 
for a auto attendant option.

Field Contains…
Code *99

Table continues…
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Field Contains…
Feature Voicemail Collect
Telephone Number ?
Line Group ID 0

Via an auto attendant
An auto attendant can be used to enable remote access to a mailbox. A short code similar to 
the example above could be entered as the Destination for one of the auto attendant Normal 
Transfer key options. For more information, see Using an auto attendant to access voicemail on 
page 60.

Related links
Miscellaneous on page 66

Mailbox Password Rules
About this task
The IP Office system controls the rules applied to mailbox passwords. These are:
• Whether the password has a minimum length and what that length is.
• Whether complexity rules are applied when passwords are changed. When applied, the 
complexity rules are:

• No forward or reverse sequence of numbers, for example 1234 or 4321.
• No repeated digits, for example 1111.
• No match to the extension number.

Note: You can set and change (though not see) mailbox passwords through the system 
configuration. The passwords set there do not need to comply with the password enforcement 
rules. However, when the password is changed by the user, the password enforcement rules are 
applied.
This process sets the voicemail mailbox password rules that the system applies to all mailboxes.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the navigation pane, click System.

3. Select Voicemail.
4. To apply system-wide password rules, select Enforcement. The following settings are then 

applied when users attempt to set or change their voicemail password.

5. The Minimum length setting set the minimum password length allowed. The default is 4 
digits.
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October 2022 Embedded Voicemail Installation 67
Comments on this document? infodev@avaya.com

mailto:infodev@avaya.com?subject=Embedded Voicemail Installation


6. Select whether the system should also enforce additional rules by selecting Complexity.

7. Click OK.

8. Save the configuration back to the system (File > Save Configuration).

Related links
Miscellaneous on page 66

Configuring buttons
About this task
The same features used for embedded voicemail short codes can also be assigned to telephone 
buttons.
For systems being centrally managed through System Manager, this task cannot be performed 
using IP Office Manager launched from System Manager. You must first disable Under SMGR 
Administration in Security Settings before you perform this task.

Procedure
1. Using IP Office Manager, receive the configuration from the system.

2. In the left navigation pane, click User.
3. Click the required user.

4. Click the Button Programming tab.

5. Click the button line that you want to change.

6. Click Edit.
7. Next to the Action field, click the … button.

8. Select Advanced > Voicemail to display the list of voicemail features.

9. Configure the fields as appropriate. See Button Programming tab field descriptions on 
page 69 for more information.

10. Repeat steps 4 through 9 for all the keys required.

11. Click OK.

12. Repeat this procedure for other users as required.

13. Save the configuration back to the system (File > Save Configuration).

Related links
Miscellaneous on page 66
Button Programming Actions on page 69
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Button Programming Actions
Action Description
Voicemail Collect Allows access to a mailbox to collect or leave messages. The mailbox and 

action are determined by the associated telephone number. This takes the 
form ?Name for message collection and #Name for leaving a message. The 
Name variable must match the user or hunt group name set in the IP Office 
configuration. On suitable phones the DSS key displays VMCol followed by the 
name.

Voicemail Off This option switches the diversion of calls to the user or group mailbox off.
Voicemail On This option switches the diversion of calls to the user or group mailbox on. 

When programmed on a DSS key, the action toggles so no separate Voicemail 
Off key is required. On suitable phones the DSS key displays VMon.

Voicemail Ringback Off This option switches new message ringback notification off.
Voicemail Ringback On This option switches new message ringback notification on. When programmed 

on a DSS key, the action toggles so that no separate Voicemail Ringback Off 
key is required. On suitable phones the DSS key displays VMRB+.

Related links
Configuring buttons on page 68

Short Codes
Embedded voicemail supports a number of short code features.

Related links
Miscellaneous on page 66
Default short codes on page 69
Short code features on page 71

Default short codes
The following default system short codes can be used with embedded voicemail.

Feature Code Description
Voicemail Collect *17 Users can access the mailbox 

associated with their extension.
Voicemail On / Voicemail Off *18/*19 Switches the diverting of callers to 

the user's mailbox on or off.
Voicemail Ringback On / 
Voicemail Ringback Off

*48/*49 Switches new message ringback 
to the user on or off.

Table continues…
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Feature Code Description
Record Message The Record Message feature is used to record announcements that 

are used when callers to a user or hunt group are queued.
*91N To record an Announcement 1 for 

user or group extension N.
*92N To record an Announcement 2 for 

user or group extension N.

Feature / Code Description
Voicemail Collect
*17 Users can access the mailbox associated with their extension.
Voicemail On / 
Voicemail Off
*18/*19 Switches the diverting of callers to the user's mailbox on or off.

Voicemail Ringback 
On / Voicemail 
Ringback Off
*48/*49 Switches new message ringback to the user on or off.

Record Message

The Record Message feature is used to record announcements that are used when callers to a user or 
hunt group are queued.
*91N To record an Announcement 1 for user or group extension N.
*92N To record an Announcement 2 for user or group extension N.
Auto Attendant

The Auto Attendant feature is used to record various auto-attendant prompts. In the default short codes, 
XX is replaced with the auto-attendant number when dialing.
*81XX Play and record the auto-attendant's morning greeting.
*82XX Play and record the auto-attendant's afternoon greeting.
*83XX Play and record the auto-attendant's evening greeting.
*84XX Play and record the auto-attendant's menu actions prompt.
*800XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 0 key. 
*801XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 1 key. 
*802XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 2 key. 
*803XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 3 key. 
*804XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 4 key. 
Table continues…
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Feature / Code Description
*805XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 5 key. 
*806XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 6 key. 
*807XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 7 key. 
*808XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 8 key. 
*809XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the 9 key. 
*850XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the * key. 
*851XX Play and record the auto-attendant's prompt for a park and page action 

assigned to the # key. 

Related links
Short Codes on page 69

Short code features
Additional short codes can be added as required using the short code features listed below. 
For more information about short codes, refer to the IP Office Manager on-line help and user 
document.

Voicemail Collect
This short code feature can be used to create short codes for collecting or leaving messages. 
The exact action is set by the use of either ? or # in the telephone number. For example, “?Main” 
indicates collection of messages in the mailbox called Main. “#Main” indicates that a user wants to 
leave a message in the mailbox called Main. Note that the quotation marks are required, and the 
name must match the user or hunt group whose mailbox is being accessed. For example:

Field Contains…
Code *99
Feature Voicemail Collect
Telephone Number “?Main”
Line Group ID 0

Question mark
Using just ? in the Telephone NumberTelephone Number without quote marks and without a 
mailbox name allows remote access. The user would be prompted to enter the mailbox number 
and then the mailbox access code if set.

Voicemail On/Voicemail Off
These two features switch the diversion of calls to the user mailbox on/off. No telephone number 
is required for either of these features.
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Voicemail Ringback On/Voicemail Ringback Off
These two features switch new message ringback notification on/off. No telephone number is 
required for either of these features.

Auto Attendant
This feature is used for the recording of auto attendant prompts and greetings. Normally the short 
codes for this are created automatically. However However, they can be deleted and reassigned 
as required. See Recording Prompts on page 55.

Record Message
Allows the recording of announcement messages for users and hunt groups.

Shutdown Embedded Voicemail
Allows the Embedded Voicemail service provided by the memory card or System SD card to be 
disabled. For IP Office Release 6 and earlier systems, this short code should be used before 
removing a memory card from the system. For IP Office Release 6 and later systems, a memory 
card shutdown command should be used instead.

Startup Embedded Voicemail
Allows an Embedded Voicemail service that has been shutdown to be restarted.

Related links
Short Codes on page 69
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Chapter 7: Mailbox Maintenance

Embedded voicemail does not support a dedicated client for voicemail configuration and mailbox 
management. However, using other standard IP Office applications, some mailbox management is 
possible.

Related links
Viewing Mailboxes on page 73
Viewing the Embedded Voicemail Files on page 73
Monitoring Embedded Voicemail on page 74
Monitoring Embedded Voicemail housekeeping on page 75
DTE Port Maintenance on page 76

Viewing Mailboxes
About this task
Using the System Status application, it is possible to view the voicemail mailboxes. The details 
include the number of messages of different types (new, read and saved) in each mailbox.

Procedure
1. Start System Status and connect to the system. If not installed on the PC, System Status 

can be started from the system by browsing to its IP address and selecting System 
Status.

2. From the navigation tree select Voicemail and then Mailboxes.

Related links
Mailbox Maintenance on page 73

Viewing the Embedded Voicemail Files
About this task
The files for embedded voicemail are all stored on the System SD card inserted into the system. 
They are all stored in the same folder, there are not separate folders for each mailbox.
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Procedure
1. Start IP Office Manager

2. Select File > Advanced > Embedded File Management.
3. Select the system and enter an administrator name and password.

4. In the navigation tree, select System SD\SYSTEM\DYNAMIC\LVMAIL.

5. The files shown are the messages, greetings and prompts for all the mailboxes.

6. Select a file to shown its details in the File Details section.

Related links
Mailbox Maintenance on page 73

Monitoring Embedded Voicemail
About this task

Use the IP Office Monitor application to observe the operation of Embedded Voicemail.

Procedure
1. Select Start > IP Office > Monitor and connect to the system.

2. Select  > Filters > Trace Options.

3. To include Embedded Voicemail events on the monitor trace, do the following:

a. On the Call tab, select the options that you want to monitor in the Embedded 
Voicemail section.

b. Set the Trace Colour to a distinctive color.

4. Click OK.
********** SysMonitor v6.0 (11031) **********
********** contact made with 192.168.42.119 at 10:08:25 15/11/2006 **********
********** System (192.168.42.119) has been up and running for 1day, 19hrs, 3mins 
and 7secs(154987775mS) **********
 154987776mS PRN: Monitor Started IP=192.168.42.130 IP 500 4.0(11031) IP500_40
  (IP Office: Supports Unicode, System Locale is eng)
154987776mS PRN: LAW=A PRI=0, BRI=4, ALOG=4, ADSL=0 VCOMP=32, MDM=0, WAN=0, 
MODU=0 LANM=0 CkSRC=1
VMAIL=1(VER=2 TYP=3) CALLS=0(TOT=6)
 154987778mS LIST2: IFACE(4) "LAN1","LAN2","DialIn","RemoteManager"
A:\lvmail\ENG\*.*
 155088356mS PRN: LVM Flash A:  NextFlashItemScan: Scanning A:\lvmail\ITA\*.*
155088456mS PRN: LVM Flash A:  NextFlashItemScan: Finished Scanning 
A:\lvmail\ITA\*.*
 155088462mS PRN: LVM Flash A:  NextFlashItemScan: Finished Scanning A:\lvmail\*.*
 155088462mS PRN: LVM Flash A:  NextFlashItemScan: END-OF-LIST found
 155088462mS PRN: LVM FlashMan:  FiveMinuteActions: called    2006/11/15 10:10:02
155088520mS PRN: LVM FlashMan:  FiveMinuteActions: Free: 955.9 MBytes ( 92% )
 155088520mS PRN:                 33 Hours 11 Minutes Approx. Remaining
 155088520mS PRN:                 FMML Size: 27
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Result
Embedded Voicemail events are now shown in the Monitor trace when running. These events are 
all prefixed LVM.

Related links
Mailbox Maintenance on page 73

Monitoring Embedded Voicemail housekeeping
About this task
Embedded Voicemail performs housekeeping approximately every 5 minutes, subject to other 
system activity. You can observe the Embedded Voicemail housekeeping by enabling the House 
Keeping trace option.

Procedure
1. From the Start menu, select Programs > IP Office.

2. Select Monitor.
3. Select File > Select Unit. The Select System to Monitor window opens.

4. Enter the Control Unit IP Address and password. Depending on how the system is 
configured, the password required is either the system password or the separate monitor 
password if set.

5. Select Filters > Trace Options.

6. On the All Settings window, under Embedded Voicemail, click the check box for 
Housekeeping to select this option.

7. Click OK.

Result
Embedded Voicemail events are now shown in the Monitor trace when running. These events are 
all prefixed LVM. Details include the approximate remaining message capacity of the memory card.
156165753mS LVM(housekeeping): FlashMan:  FiveMinuteActions: called    2009/01/29 
06:52:55
156165796mS LVM(housekeeping): FlashMan:  FiveMinuteActions: Free: 426.4 MBytes ( 81% )
156165796mS LVM(housekeeping):                 14 Hours 48 Minutes Approx. Remaining
156165796mS LVM(housekeeping):                 FMML Size: 35

Related links
Mailbox Maintenance on page 73
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DTE Port Maintenance
About this task
Using a serial cable, it is possible to perform a range of commands on the system running 
embedded voicemail. See the "Installing IP500 V2" manual for details of the cable required and 
the serial port settings.

Warning:
• These options should be used with caution. The DTE interface includes other options 

that can erase the whole systems software and configuration.

Procedure
1. Connect to the system using a serial cable.

2. Enter AT. The system should respond OK.

3. Enter AT-DEBUG. The system will respond with hello >.

4. Enter ivm-help. The system responds by listing the mailbox and message commands. 
These are:

Choice Option Choice Description
ivm-mbox-show Show the details of all mailboxes.
ivm-mbox-show nnn Show the details of the mailbox specified.
ivm-mbox-clear nnn Delete all messages, prompts and recordings relating to the 

mailbox specified.
ivm-msg-del nnn 
yy/mm/dd hh:mm:ss

Delete all messages in the mailbox extension number specified up 
to the date specified. If the date is omitted then all messages are 
deleted.

ivm-msg-del-all Delete all mailbox messages.
ivm-status-show Show the summary of the embedded voicemail status.
ivm-tls-show Show the current status of SMTP TLS.
ivm-tls-set Y/N Set the current status for STMP TLS.

Related links
Mailbox Maintenance on page 73
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Chapter 8: Additional Help and 
Documentation

The following pages provide sources for additional help.

Related links
Additional Manuals and User Guides on page 77
Getting Help on page 77
Finding an Avaya Business Partner on page 78
Additional IP Office resources on page 78
Training on page 79

Additional Manuals and User Guides
The Avaya Documentation Center website contains user guides and manuals for Avaya products 
including IP Office. 

• For a listing of the current IP Office manuals and user guides, look at the AvayaIP Office™

Platform Manuals and User Guides document.

• The AvayaIP Office Knowledgebase and Avaya Support websites also provide access to the 
IP Office technical manuals and users guides.

- Note that where possible these sites redirect users to the version of the document hosted 
by the Avaya Documentation Center.

For other types of documents and other resources, visit the various Avaya websites (see 
Additional IP Office resources on page 78).

Related links
Additional Help and Documentation on page 77

Getting Help
Avaya sells IP Office through accredited business partners. Those business partners provide 
direct support to their customers and can escalate issues to Avaya when necessary.
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If your IP Office system currently does not have an Avaya business partner providing support and 
maintenance for it, you can use the Avaya Partner Locator tool to find a business partner. See 
Finding an Avaya Business Partner on page 78. 

Related links
Additional Help and Documentation on page 77

Finding an Avaya Business Partner
If your IP Office system currently does not have an Avaya business partner providing support and 
maintenance for it, you can use the Avaya Partner Locator tool to find a business partner. 

Procedure
1. Using a browser, go to the Avaya Website at https://www.avaya.com

2. Select Partners and then Find a Partner.
3. Enter your location information. 

4. For IP Office business partners, using the Filter, select Small/Medium Business.

Related links
Additional Help and Documentation on page 77

Additional IP Office resources
In addition to the documentation website (see Additional Manuals and User Guides on page 77), 
there are a range of website that provide information about Avaya products and services including 
IP Office.

• Avaya Website (https://www.avaya.com)

This is the official Avaya website. The front page also provides access to individual Avaya 
websites for different regions and countries.

• Avaya Sales & Partner Portal(https://sales.avaya.com)

This is the official website for all Avaya business partners. The site requires registration for a 
user name and password. Once accessed, the portal can be customized for specific products 
and information types that you wish to see and be notified about by email.

• AvayaIP Office Knowledgebase(https://ipofficekb.avaya.com)

This site provides access to an online, regularly updated version of IP Office user guides and 
technical manual. 

• Avaya Support(https://support.avaya.com)

Additional Help and Documentation
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This site provide access to Avaya product software, documentation and other services for 
Avaya product installers and maintainers.

- Avaya Support Forums(https://support.avaya.com/forums/index.php)

This site provides a number of forums for discussing issues. 

• International Avaya User Group(https://www.iuag.org)

This is the organization for Avaya customers. It provides discussion groups and forums.

• Avaya DevConnect(https://www.devconnectprogram.com/)

This site provides details on APIs and SDKs for Avaya products, including IP Office. The 
site also provides application notes for 3rd-party non-Avaya products that interoperate with IP 
Office using those APIs and SDKs.

• Avaya Learning(https://www.avaya-learning.com/)

This site provides access to training courses and accreditation programs for Avaya products.

Related links
Additional Help and Documentation on page 77

Training
Avaya training and credentials are designed to ensure our Business Partners have the capabilities 
and skills to successfully sell, implement, and support Avaya solutions and exceed customer 
expectations. The following credentials are available:

• Avaya Certified Sales Specialist (APSS)

• Avaya Implementation Professional Specialist (AIPS)

• Avaya Certified Support Specialist (ACSS)

Credential maps are available on the Avaya Learning website at http://avaya-learning.com/.

Related links
Additional Help and Documentation on page 77

Training
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